Support » Plugin: The GDPR Framework By Data443 » The plugin could not be activated because it caused a fatal error

  • Resolved carlajesus

    (@carlarrj)


    Hello,

    I’ve installed the plugin but I can not turn it on, it shows the “Parse error: syntax error, unexpected ‘[‘ in /wp-content/plugins/gdpr-framework/gdpr-framework.php on line 87”. What can I do?

    Can anyone help?

    Thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi there!

    The plugin requires at least PHP 5.6, but it looks like your server has an older version. Older versions than PHP7 are actually already outdated, so I recommend you contact your web hosting provider and ask to upgrade.

    Good luck!

    Hi,

    i have php 7.0.7 …

    Fatal error: Uncaught Error: Call to a member function bindIf() on null in /wp-content/plugins/gdpr-framework/bootstrap.php:7 Stack trace: #0 /wp-content/plugins/gdpr-framework/gdpr-framework.php(95): require_once() #1 /srv/www/htdocs/sutter/wp-admin/includes/plugin.php(1897): include(‘/srv/www/htdocs…’) #2 /wp-admin/plugins.php(172): plugin_sandbox_scrape(‘gdpr-framework/…’) #3 {main} thrown in /srv/www/htdocs/sutter/wp-content/plugins/gdpr-framework/bootstrap.php on line 7

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘The plugin could not be activated because it caused a fatal error’ is closed to new replies.