Support » Plugin: WooCommerce Admin » The plugin breaks wp-admin, still

  • Resolved matstillo

    (@matstillo)


    Hi there,

    I’m subscribed to the following topic:

    https://wordpress.org/support/topic/the-plugin-breaks-wp-admin/

    It is about an issue where you cannot log into a site admin with the WooCommerce Admin plugin active. It gets stuck in a redirect loop. The only solution is to login directly to the wp-admin/index.php file.

    On that linked thread, I was engaging with a developer (Thomas Shellberg) on the plugin, as I was experiencing the exact same issue. However, when I returned to reply to a message on the thread, I could see that all my comments/replies, along with another user who had experienced the same and commented, had been removed & the topic marked resolved? It really isn’t resolved for me, it’s happening on multiple sites.

    I’m currently in development on a site that invested heavily, time and costs, in all the WooCommerce Membership & Subscriptions systems. Unfortunately it seems like this plugin is now tied into all the Analytics reporting we have promised the client, so it’s not even a matter of just deactivating it for now. I need to fix this. It will likely mess up all the user login processes as well, so I can’t fallback on the ‘just add /index.php’ method.

    As I had mentioned in my initial comments, it was happening on a fresh install, with only WooCommerce plugins added. I haven’t had the luxury of holding up the whole site dev till this was fixed, so there are more plugins in place now.

    It’s quite possible this is a server setup, or permalinks issue, but WooCommerce Admin is the only plugin that causes it, so I really need your help to get to the bottom of things please.

    I had supplied permalink settings and .htaccess files in my thread, perhaps this can still be accessed? Otherwise I can resend.

    Many thanks in advance!

    Mat

    PS, the plugin does seem to keep re-activating itself as long as it remains in my plugins folder. Is that normal?!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi there @matstillo

    As I had mentioned in my initial comments, it was happening on a fresh install, with only WooCommerce plugins added.

    To confirm – you experience this problem with only WooCommerce active or with only plugins purchased from WooCommerce.com?

    Can you replicate this with only WooCommerce and the Storefront theme active? I haven’t been able to replicate that and I do have the WooCommerce Admin plugin active on a few test sites with varying levels of active plugins.

    PS, the plugin does seem to keep re-activating itself as long as it remains in my plugins folder. Is that normal?!

    No, that isn’t normal.

    Can you let me know which circumstances you can replicate this with, please?

    Thanks,

    Plugin Support thup90

    (@thup90)

    Hi there,

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘The plugin breaks wp-admin, still’ is closed to new replies.