Support » Plugin: Twitter Widget Pro » the plug-in has stopped updating tweets

  • Resolved sofiap


    The plug-in has stopped updating tweets two weeks ago. I tried deactivating and reactivating it. I tried doing the authentication process again. Nothing seems to help. (Please not, I am not a programmer and don’t usually mess around with the code. I am open to trying a fix that way, but please explain it in layman’s terms; otherwise, I will be too wary to try it for fear of making the problem worse.)

    Thanking you in advance.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Aaron D. Campbell


    The new version (2.6.0) did fix an issue that affected a couple specific versions of PHP (there was a bug in PHP that I had to work around). Other than that, the issue with a feed not updating is usually due to one of the following:

    1. Your account has hit it’s API call limit. You can see your rate limit status by looking at the settings page (WP Admin->Settings->Twitter Widget Pro). Remember that all apps that you authenticate to your Twitter account are using your API calls, so they’re not necessarily all being used by Twitter Widget Pro. Twitter Widget Pro actually uses only 20 calls per hour per distinct widget (a distinct widget is a widget with the same settings, so same username, number of tweets, etc).
    2. Your server is limiting loopback calls. This basically means that your server is keeping your site from calling itself. Whenever a user is visiting your site and Twitter Widget Pro determines that you need updates from Twitter, it actually calls another page on your site that does the update. This way the user doesn’t have to wait while all the processing is being done. There have been some hosts that have turned off this functionality or blocked it with their firewalls. If this is the case, Twitter Widget Pro cannot update
    3. Some people have also had problems with some locks not clearing. There is a lock put in place to keep Twitter Widget Pro from trying to update the feed when it’s already updating the feed in another process. There is a link on the settings page labelled “Clear Update Locks” that you could use to clear the locks and see if it helps.

    I will look into all of these possibilities. Thanks for your help. Much appreciated.

    Hi there,
    I’m having the same problem. It was working fine a few days ago.
    I cleared update locks, but that didn’t solve the problem.

    Plugin Author Aaron D. Campbell


    IDGrafix: Did you check #1 and #2 above as well?

    In my case, I had to disable a security plug-in that I had customized for the site. Once I reinstalled it with only the basic functions, it no longer interfered with the Twitter Widget Pro plug-in. I mention this in case that’s your situation as well.

    Hi Aaron and Sofiap,

    I tried de-activating my WP Better Security plugin, but unfortunately that didn’t change anything.

    I haven’t changed my provider and received no announcement regarding limiting loopback calls.

    This is what my status says:

    Used: 5
    Remaining: 175
    Limits reset in: 13 minutes
    This is overall usage, not just usage from Twitter Widget Pro


    I was using that same WP Better Security plugin, and I had increased security levels on several settings (after I installed it). I had to delete the plug-in entirely, and reinstall it, and then left it at the default settings to see what would happen. The Twitter Widget then began to work again.

    Hi Sofiap,

    I just de-installed the entire plugin, but my tweets are still not showing up. The weird thing is that they were recently showing up with my security plugin activated. And I haven’t changed anything on my site in a long time and just happened to notice that my tweets had disappeared.

    Thanks a lot for your suggestion though which might save a lot of time to other people trying to decipher a similar enigma to an identical symptom 🙂

    Sorry it didn’t solve your problem. I am by no means an expert, but I noticed that my Twitter widget probably started happening around the time that I installed the WP Security plug-in, so I figured it was related. For me it was. Too bad it wasn’t such an easy fix for you.

    All of a sudden my tweets are back without any change. 🙂 It might have been a Twitter problem. Thanks for your help. Cheers

    For those who may be searching to fix this issue in the future. I use Better WordPress Security, which is an excellent plugin, but the way that I had it configured was interfering with Twitter Widget Pro. It is neither’s fault, they are both doing what they should. Turn off, or tweak your settings with BWS, and you should find that you feeds update again.


    Did You get which tweeks in BWS are those interfering with Twitter Widget Pro?

    Hi, my Twitter feed is working again with BWS. In my case, I do not think the problem was related to BWS (set up with much more than the default settings).


    No, I’m sorry, I did not. I was in a rush to fix the issue, and simply turned it off.

    Aaron D. Campbell, in point 2 of a previous comment in this thread said “2. Your server is limiting loopback calls. This basically means that your server is keeping your site from calling itself.”.

    I called the hosting company, GoDaddy, to find out what their limit was. 10 hits per minute, that is, once per 6 seconds.

    I then reasoned that it’s possible that BWPS might be limiting that, or, perhaps that TWP might attempting to access a file that is either (for some unknown reason) blocked or limited by BWPS.

    As soon as I turned it off, her twitter feed updated. Since it solved the problem, and I have a reasonable amount of trust for the GoDaddy network, I left it off.

    However, should Mr. Campbell discern a cause, based on these further observations and speculations, I’d like to know. I consider BWPS to be essential in most of my installs, and I might use TWP on another install at some point.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘the plug-in has stopped updating tweets’ is closed to new replies.