Support » Themes and Templates » The permalinks don’t work on search function

  • Resolved shahpur

    (@shahpur)


    Hi,

    im using the streamline theme and i have following problem:

    when somebody uses the search function the results are shown correctly, but the post summaries don’t open the whole post if clicked on.

    Example of a search:

    Example

    It seems like the php function “the_permalink()” is not working on this page, because in the link tag will show an empty ‘href’-value in the source code. So clicking on any post will just result in reloading the search result screen.

    On all other pages the permalink function is working correctly, so i don’t know what the reason for this is. Since the search is placed at the top of the sidebar its important for me that it works.

    Can somebody help me out? I really love this theme and i don’t want to use any other theme.

    Thanks,
    Shahpur

Viewing 6 replies - 1 through 6 (of 6 total)
  • chaoskaizer

    (@chaoskaizer)

    paste your theme’s search.php at http://wordpress.pastebin.com/

    shahpur

    (@shahpur)

    Hi,

    i uploaded my search.php:

    Search.php

    It would be great if you could tell me whats going wrong with the permalinks.

    Bye,
    Shahpur

    t31os

    (@t31os)

    It’s this part..

    <?php the_permalink ?>

    It should be..

    <?php the_permalink(); ?>

    Line 30 and Line 34.

    shahpur

    (@shahpur)

    Hi t31os,

    thanks so much. It works now!

    How embarassing that i didn’t see the mistake, that the function wasn’t called correctly…

    Bye,
    Shahpur

    t31os

    (@t31os)

    I missed it too to start with, had to re-read it a few times before spotting it, easily done…

    9thsphere

    (@9thsphere)

    Hi,

    The problem should be fixed in the new 1.1.3 version that is ready for download.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘The permalinks don’t work on search function’ is closed to new replies.