Support » Fixing WordPress » “The password field is blank”

  • I’m experiencing some big problems…but before I start…if you tell me to “search”, I will hunt you down, forcibly migrate your site to a 386 running Linux off a 2400-baud modem, and then taunt you mercilessly. 🙂 I’ve searched here, I’ve gone through Google, etc.
    Here’s some info: PHP 4.3.9, Apache 1.3.33, MySQL 4.0.22, Linux (2.4 kernel)
    (so here’s a hint – don’t try to give me the IIS-specific fix – I even tried it for kicks and grins!)
    For a while, I’d been having problems with redirects not working under 1.2. I’d approve a comment in moderation, and it would just say “wordpress 1.2, 0.02 seconds”. If I directly entered a page address, it would work fine.
    So, I decided to do the upgrade to 1.2.1. Actually, given my DB had cruft in it dating back to b2 0.6, I did a fresh install into /wordpress (existing was in /blog), installed into a fresh DB, then migrated my tables over. Everything was running good, so I decided to make the swap. I updated the WP directory and blog address to /blog/, and did the folder renaming.
    Next time I clicked the login button from my blog, it gave me the login dialog. I re-enter my username and password, I get the “ERROR: The password field is blank” error message. It doesn’t set login cookies. (it’s not a security issue – I have gallery2 on the same domain, and it can set a login cookie).
    So, I’ve got a useless site right now. I’m going to see if I can hack together a bypass script that will manually set my login cookies, but there’s still something messed up here.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff


    Try emptying your browser cache and deleting all WordPress-related cookies.

    Already done. Like I said, I’ve searched the site extensively and tried pretty much everything previously suggested.

    Oh, and if you’d like to try it yourself, I created a level-1 user:
    Ben’s weblog wp-login.php
    username: testuser
    password: testuser

    Bumping this up – this is a critical bug.

    Mark (podz)


    Support Maven

    This may be wrong, but how did you upload your files ?
    When I View Source on the login page, I see a lot of whitespace at the top which is not normally there. While that’s not maybe the direct cause, it suggests to me that something could have gone wrong with the ftp.

    Beats me as to how the whitepsace got there. I just put the ZIP file up onto the server and used CPanel’s built-in file manager to uncompress everything. Wonder if that causes problems with CRLF vs LF line endings?
    I’ve got a busy day of yardwork ahead, so I’ll try uploading everything manually and let you know how that works if I have a free hour later on tonight. I did see someone had success with a 1.2-mingus version of the wp-login.php file in a separate thread, so I’ll try that as well.

    I uploaded my old WP 1.2 (Mingus) wp-login.php file over the 1.2.1 file (and I had the same problem on an Apache server mind you). And I can get in and manage my site. But there are some new nits cropping up, surely as a result of my surgery on wp-login.php?? Now when I SUBMIT a new post, I get a blank screen. I just have to click on my bookmarked copy of my blog to get to its front page and then hit the Admin link, which is a PITA but it sure beats not being able to get in at all! And it looks like the same thing happens when you SUBMIT a comment. Got something to do with GET or POST? All roads are leading back to the Mingus version, aren’t they? I mean, if I have to patch this file and that with the Mingus versions, why don’t I just downgrade to it. I looked at the changelog and looks like I ought to go back to 1.2.0 until all this is sorted out, right?

    Thanks for the recommendation. I wiped the directory and uploaded all of the files via FTP instead of just the ZIP file and opening it in CPanel. At the moment, everything seems to be working OK. I’ve still got to re-install all of my plugins and hacks, but this looks like it helped.
    I think the problem is (like I mentioned) due to DOS-style line endings (CRLF) vs Unix-style (LF) – that caused all the blank lines you saw in the source, and it gets exacerbated when you use the built-in text file editor and/or file uploading utilities built into CPanel. Doesn’t exactly speak well to the robustness of the code (whether it’s WP, CPanel, or even just PHP, I don’t know)…but at least now we know what the solution to the problem is – straight FTP is the way to go.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘“The password field is blank”’ is closed to new replies.