Support » How-To and Troubleshooting » the page links don’t work

the page links don’t work

Viewing 3 replies - 1 through 3 (of 3 total)
  • Try settings/permalinks

    The codex recommends using index before the page name e.g.

    custom structure index/%postname%/

    Thanks, I tried changing the setting/permalink page which didn’t work, but the permalink on the page edit page let’s me change them one at a time. I have never had to do that before, they always just worked.

    Thanks for getting back to me so fast!

    The page format you mentioned (i.e. ?page_id=#) is used if permalinks are NOT setup. If you do have permalinks turned on, then the url for your pages is determined by the post-slug, which located right below the title in the page editor. I think this is new in WP2.5. Also, the permalinks settings in wp-admin set the url rules for the posts (not the pages).

    See Changing the URL (or “Slug”) of Your Pages for more information.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘the page links don’t work’ is closed to new replies.
Skip to toolbar