WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Change size of editor missing in WP 3.5???? Help

[Resolved] Change size of editor missing in WP 3.5???? Help

  • How to Change size of editor in WP 3.5

    The size of the editor is small and I wanted to change that. In the previous version I went to writing and on the top there was an option to change “size of post box”

    This seems to be missing in WP 3.5.

    Can someone advise me how to change the size?

    Thanks

    Dita

Viewing 15 replies - 16 through 30 (of 32 total)
  • @robert
    Thanks for information about patching the two files/ed_size. I changed to 800 what is similar to my settings in 3.42 before. That helps for now.

    Hopefully there will follow an official patch soon:)

    If you are using the Qtranslate plugin I’ve used a quick and dirty solution through CSS.

    In plugins Qtranslate click on Edit
    select this file: qtranslate/qtranslate_hooks.php

    scroll down until you find this line:
    echo “#qtrans_textarea_content { padding:6px; border:0 none; line-height:150%; outline: none; margin:0pt; width:100%; -moz-box-sizing: border-box;”;

    Inside this CSS I’ve added height:400px;

    Looks like this:

    echo “#qtrans_textarea_content { padding:6px; border:0 none; line-height:150%; height:400px; outline: none; margin:0pt; width:100%; -moz-box-sizing: border-box;”;

    Hopes this helps some people for a while, you can set any height you wish it to be. It’s very quick and dirty at least it solves the annoyance of having to drag it all the time 😉

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    Still not able to reproduce this… The ed_size would not be saved if the value is too big or too small, only when it’s in the range 50px — 5000px.

    Added a patch on the new ticket few days ago: http://core.trac.wordpress.org/attachment/ticket/23042/23042.patch

    @robert, @missinmedia could you check if that patch fixes it for you? Also can you try resizing the Text editor too.

    To see the current ed_size that is in your cookie run this in the browser console:

    getUserSetting('ed_size');

    After resizing the editor, the returned number should change accordingly. Also, to set it manually you can do:

    setUserSetting('ed_size', 200);

    The change should be visible after reloading the page.

    Hey Andrew! Sorry to be a remedial noob, but how do you run that in the browser console?

    And, any chance that the Number of Lines for the Editor setting we used to have in 3.4.2 will return?

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    To run it go to Edit Post screen and:

    – In Chrome right-click anywhere on the page and select “Inspect element”. That will open the developer tools at the bottom, click on the Console tab, then paste that JS code and press Enter.

    – In Firefox go to “Web developer -> Web console” from the menu at the top or if you have Firebug, go to the console there. Paste the JS in the thin box at the bottom and hit Enter.

    – In IE > 8 hit F12, go to the Console tab, paste in the box at the bottom and hit Enter.

    Don’t think that setting will return. It was mostly irrelevant as it would affect only the Text editor and only when the Visual editor was never used. As soon as the user resized the Visual editor, the textarea height was matched to it.

    Andrew, Thank you for this tip.
    I’m getting this number in Firefox “64476666”. It is quite high.

    After resizing the post edit box to about an inch and a half high, I get this number: “15276666”.

    The set user edit size to 200 works. After I use it the number in Firefox is: “200”

    But, is that only for me as the logged in user?

    This is of great concern as I created this site for non WP saavy folks to login and create posts. Below the post edit box are the custom fields they need to access. They won’t know they are there at this point.

    Thank you for any help in getting back to a manual box size setting.
    Nancy

    Moderator Andrew Ozz

    @azaozz

    WordPress Dev

    @nancyeb01 the editor height is per-user setting, so other users will have a value there after they resize the editor or will use the default of 360px.

    It would be very helpful to track where these huge values come from. Have you used 3.5-beta before updating to 3.5 (final)? Also what browsers/versions have you used the first time you saw this and right before that. Are you still able to reproduce this (the huge number for ‘ed_size’) when you resize the editor now?

    I get huge editor heights, and I did not use any beta version before updating to 3.5 final. Resizing does not “stick.” (I have not taken the time to try to fix this. It really should work out of the box!)

    Moderator Mark Ratledge

    @songdogtech

    Forum Moderator

    @inge12: It’s impolite to interrupt another poster’s ongoing thread with a question of your own and it causes significant problems for the forum’s volunteers. Please post your own topic.

    @andrew:
    Today I deleted the old cookie-file and changed the two files I patched before (as described by Robert here in this thread) back to the original ones. Now the editor size seems to work perfect. It “remembers” the size of the edor window and doesn’t “explode” to giant size as before.

    Deleting the old cookie-file solved – as far as I can see in the moment – the problem for me now.

    Thanks @andrew Ozz, the console JS update seemed to have sorted it for me, im going to check the other users who are Authors to see what there Post Box is like.

    Cheers
    Steve

    @andrew:
    I don’t think I used 3.5-beta before updating to 3.5. The version of Firefox I am using is 17.0.1 and believe I have been on for a few weeks (I am on the release update channel) I get the same long edit field in IE 9.

    I just ran some tests to see if it was my theme or plugins. I tested on a site with WP 3.4.2; no active plugins running and WP theme 2012.

    I upgraded the site to 3.5. I still have the extremely long window – size was “432876666” in one instance. Sometimes it holds the re-size, sometimes becomes extremely long. This is true in Firefox and IE.

    I will continue testing.

    Thanks for your thoughts on this. If you need a login please let me know.

    @robert and @andrew:
    I applied the above patches, and took Roberts advice to “change the ed_size code from 5000 to 500 pixels”. That seems to work.

    Thank you!

    @songdogtech
    Seemed to me that the original poster (ebizdame) was no longer in the conversation.

    If I were trying to solve the problem, rather than seeking a solution, I would appreciate input from others with the same problem but possibly slightly different symptoms. Every little bit of info helps. Opening a new thread on the same problem would make it more difficult to solve, in my opinion. But maybe that’s just me …

    Thank you, Robert and Andrew, for your very helpful input.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘[Resolved] Change size of editor missing in WP 3.5???? Help’ is closed to new replies.
Skip to toolbar