WordPress.org

Forums

The oddest error I've ever seen. (22 posts)

  1. Andrewaclt
    Member
    Posted 9 years ago #

    I can post anything on my wordpress blog except:

    If I were chained to a bench and 'perl' was the only thing that could open the lock, I'd probably cut my hand off.
    -Gerald Penn

    Everytime I do that it gives me a 500 Internal Server Error. Any idea what the issue is? My host took a look at it and was baffled too.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    perl

    If you try and post curl or python or lynx you get the same effect.
    Some sort of security setting that protects us from malicious scripts :)

  3. Andrewaclt
    Member
    Posted 9 years ago #

    How do you blog the word perl then? That's a horrible solution to the problem.

  4. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Odd.. I went to try, and I can post that whole thing with no problem. Have you tried that sentence without the word 'perl' in ?

  5. Andrewaclt
    Member
    Posted 9 years ago #

    yes, I tried it without and it worked fine. I just tried it again and it works fine when I do 'p-erl' but not when I post 'perl'...

    :(

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

  8. Andrewaclt
    Member
    Posted 9 years ago #

    none of your suggestions have worked, the perl  didn't work either.

  9. Ryan Duff
    Member
    Posted 9 years ago #

    Did you try double quotes instead of single quotes?

  10. Denis de Bernardy
    Member
    Posted 9 years ago #

    I had the same problem at a time with the word SELECT. I never got this working for WordPress and rephrased the sentence; and the bug I submitted got flagged as false alarm, on grounds it was a server problem rather than a wordpress problem.

    When I bumped into the same problem with another tool, I found the following: When I send a few keywords to my server via a GET request, it savagely produced errors; and for some reason, doing the same thing via the POST method will fix this. Since then, I no longer use GET requests for updates (I believe there are a couple of those in WP) and everything works fine. Might work for you too.

  11. shanelavalette
    Member
    Posted 9 years ago #

    what do you do when all of your pages suddenly give a 500 internal server error?

  12. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You delete your .htaccess file.

  13. shanelavalette
    Member
    Posted 9 years ago #

    thanks. that was odd.

  14. shanelavalette
    Member
    Posted 9 years ago #

    but now my archive pages have disappeared and i get a 404 error (my monthly pages) -- what do i do, then?

  15. Mark (podz)
    Support Maven
    Posted 9 years ago #

    What happened right before the 500 error ?

    What you need is new permalinks.
    Open Notepad
    Press the spacebar once
    Save the document as 'htaccess.txt'
    Upload to the same place as your 'wp-rss2.php' file
    Change it's name to .htaccess
    Change it's permissions to 666

    then Options > Permalinks and make a new structure.

  16. shanelavalette
    Member
    Posted 9 years ago #

    and for some reason i can't make a particular post -- it just won't show up.

  17. shanelavalette
    Member
    Posted 9 years ago #

    ... when i make a certain post followed by another, it makes the one in front of it invisible on the website.

  18. Andrewaclt
    Member
    Posted 9 years ago #

    I've tried double and single quotes and everything else I can think of...it's kinda annoying.

  19. shanelavalette
    Member
    Posted 9 years ago #

    I noticed that something with the quotes was messing it up, actually. Ironic.

    Anyway, thanks for all the help. My new site is slowly coming together and I'm getting the hang of wordpress.

  20. Andrewaclt
    Member
    Posted 9 years ago #

    Any other suggetions? It's happening again and it doesn't seem to want to post something that doesn't mention perl at all, at least is there a list of words that has this error?

  21. Andrewaclt
    Member
    Posted 9 years ago #

    Developing feature full firmware that is stable and works properly is a
    time-consuming task.

    It's not letting me post that sentence...and it took me thirty minutes to narrow it down to that.

  22. pericat
    Member
    Posted 9 years ago #

    From following links in the other threads podz mentioned, it looks like a mod_security issue. 'mod_security' is an Apache module. Not all hosts install it; if yours does, you may run into this problem.

    For Internal 500 errors (which are also Apache errors rather than WP), if replacing your htaccess file does not solve the issue, you should contact your provider's tech support. When I had problems earlier this year, the sysadmin said it was caused by "a low limit on the number of concurrent apache processes." He raised the limit and all was well.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags