Support » Plugin: WooCommerce Multilingual & Multicurrency with WPML » The new version gives a error

  • Resolved robinofiets

    (@robinofiets)


    The new version will give a error:

    Fatal error: Can’t use function return value in write context in [website]/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-cart.php on line 209

    When i change this line to:

    $res = preg_match( '/\.'.$attachment.'$/',  $_SERVER['REQUEST_URI']);
                    if( !empty($res))

    Everything will work again, i read it has something to do with the PHP version.

    • This topic was modified 5 years, 8 months ago by robinofiets.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Thank you for reporting this! You’re right: this has something to do with older versions of PHP that we don’t support. So we didn’t test for that. We’ve fixed this issue. Thanks again!

    Even if we added a fix for this, we recommend updating to PHP 5.6 or later since this is the minimum version supported not only by WooCommerce Multilingual but the rest of the required WPML plugins as well.

    To fix it for this version, you only need to reinstall the current version – 3.9.1

    Hi Robinofiets,
    Thanks for report this.

    In our requirements we support PHP 5.6 or later and this happened for PHP prior 5.5.

    In case this is not big change so we fixed this for your ( and other people who still use old PHP, but we suggest update it ), but without pushing new version so please update your plugin from wordpress.org now

    Hello, the issue reported here should be resolved.
    I am going to mark this ticket now as resolved.
    If your issue still persist, please open a new ticket in our forum at wpml.org.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘The new version gives a error’ is closed to new replies.