• Resolved Dominik Kozmáli

    (@dominokozmali)


    After updating the plugin to version 5.9.4, an error message started appearing when editing any page – which is displayed from 15 to 60 seconds before it disappears and lets me edit the page itself.

    The error message looks like this: Warning: foreach () argument must be of type array|object, string given in /www/doc/www.kozmali.sk/www/wp-includec/script-loader.php on line 2641 (I am also sending a screenshot: https://pasteboard.co/PK9HZfeznxIn.png)

    Even though I changed the given file “script-loader.php” to the one backed up from 2 weeks ago, the error still appears. So the problem is not in this “script-loader.php” file.

    I discovered the error by disabling and activating all the plugins one by one and looking for the “culprit” and discovered that when I disabled this Contact Form 7 plugin, the error message stopped appearing.

    So I’ve downgraded the plugin to version 5.9.3 (in which it’s fine) for now until the buggy 5.9.4 issue is resolved.

    Can you please fix this error?

    (I already contacted the provider of my wordpress theme “The7” and he told me that the error is on the side of the plugin, because it also appears with the standard WP theme “TwentyTwentyFour”, so the theme is fine).

    Thank you

    Sincerely

    Dominik Kozmáli

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    Thread Starter Dominik Kozmáli

    (@dominokozmali)

    Hi @takayukister

    I only use the “The7” theme (latest update) on the site, specifically this template: https://the7.io/g-creative/ and my WP version is: 6.4.4

    And these are all my Active Plugins (all have the latest update, except yours):

    a3 Lazy Load

    Akismet Anti-spam: Spam Protection

    Automatic YouTube Gallery

    Anti-Spam by CleanTalk

    Bulk NoIndex & NoFollow Toolkit (by Mad Fish)

    BackUpWordPress

    Cache Enabler

    Buy Me a Coffee – Button and Widget

    Duplicate Page

    Contact Form 7 (your plugin version 5.9.3)

    Exit Popup

    Enable Media Replace

    Flexible Spacer Block

    Gosign Advanced Separator Block

    GTranslate

    Hover Effects

    Limit Login Attempts Reloaded

    Icon Separator

    Loco Translate

    Login No Captcha reCAPTCHA (Google)

    LoginPress

    Most and Least Read Posts Widget

    Partnerský systém Martinus

    Plugin Organizer

    podcast player

    Podcast Subscribe Buttons

    Read Meter – Reading Time & Progress Bar for WordPress.

    Rank Math SEO with AI Best SEO Tools

    Real-Time Find and Replace ProRead More

    Redirection

    ReCaptcha v2 for Contact Form 7

    Simple Custom CSS and JS

    Section Separator – BlockSmart Custom 404 error page [404page]

    Site Kit by Google

    Subscribe button Widget

    WP file manager

    SVG SupportSuper RSS Reader

    TinyPNG – compression of JPEG, PNG and WebP images

    The7 Elements

    Wordfence Login Security

    Ultimate floating widgets

    WordPress Popular Posts

    Wordfence Security

    WP Dark Mode

    WP Fastest Cache

    WP Mail SMTP

    WP Reactions Lite

    WP show more

    WPBakers Page Builder

    WPFrom Email

    YouTube Subscribe Bar

    I tried turning off all the others one by one, except yours, but the error only occurs when your plugin is enabled in the new version 5.9.4. While version 5.9.3 is fine (that’s why I switched to it temporarily) but of course I would like to use your latest version.

    Thread Starter Dominik Kozmáli

    (@dominokozmali)

    Hello @takayukister , did you get my reply?

    Sincerely

    Dominik Kozmáli

    Thread Starter Dominik Kozmáli

    (@dominokozmali)

    Hello @takayukister ,

    please how long does it take to solve a similar case or provide an answer so that I know when (and if) I should contact you (because I provided all the information you requested, so I don’t know if it helped you in solving the problem or if I have something else for you to provide)?

    Thank you very much for your answer

    Sincerely

    Dominik

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Next week I’m planning to release v5.9.5 that omits some redundant code that registers scripts to load. I’m not sure if it will fix your problems, but I think it’s worth trying.

    Thread Starter Dominik Kozmáli

    (@dominokozmali)

    Great, thank you very much for the answer and the work on the problem. I appreciate it :). Yes of course, as soon as the 5.9.5 update is released I will install it and let you know. Thank you 🙂

    Thread Starter Dominik Kozmáli

    (@dominokozmali)

    Hi @takayukister great, the 5.9.5 update successfully solved the problem :). Thank you, the problem when opening the page editor is now solved 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.