WordPress.org

Forums

[resolved] The Network creation panel is not for WordPress MU networks. (21 posts)

  1. ingenuity
    Member
    Posted 4 years ago #

    I have WP 3.01, which was an upgrade from WP 2.x. I have only one site active. I think the site may have been originally set up as multiuser site. All was well, but now, after upgrading a few plugins, I'm getting a nag saying, "Thank you for Updating! Please visit the Update Network page to update all your sites." When I click on Update Network link, I get this error:

    The Network creation panel is not for WordPress MU networks.

    I also get the same error if I click on Network Admin from the upper right corner of the dashboard.

    What can I do to set things right and no longer have the nag, and either have the Network Admin link work or disappear? At this point I don't need Multisite, but I might in the future and would like to keep the option if possible.

  2. If you only have one site active, then you don;t need to upgrade the other sites.

  3. ingenuity
    Member
    Posted 4 years ago #

    Thanks for the response.

    Then how can I get rid of the nag that says, "Thank you for Updating! Please visit the Update Network page to update all your sites."? Are you saying that, if I did create a second site, that I then would be able to click the link to Network Admin and would see something other than, "The Network creation panel is not for WordPress MU networks."? TIA!

  4. Yes, that should fix it.

  5. ingenuity
    Member
    Posted 4 years ago #

    Andrea_r, thanks for the reply. I wonder if there is something wrong with my WPMU, for I don't see a way to add a second site. While logged in as admin I see Dashboard/My Sites. On the My Sites page, it lists the primary site and offers links to visit or dashboard. I don't see an add site option. Can you please clue me in?

  6. Go to yourdomain.com/wp-admin/network/

    The 'Right now' panel has two options: Create a New Site | Create a New User

    OR on teh Sites Menu are two options:

    Sites
    Add New

  7. ingenuity
    Member
    Posted 4 years ago #

    This is why I think something is wrong with my site. When I go to http://iyta.org/wp-admin/network, I get that message, "The Network creation panel is not for WordPress MU networks." I have no idea how to fix it. Suggestions?

  8. When you upgraded to 3.0, what did you do? Did you add the network stuff to your wp-config.php file?

  9. I have never even seen that message, so I don't know.

  10. AHAH!

    That message is shown only if you've *upgraded* from WordPressMU and you're trying to create a network.

    http://iyta.org/wp-admin/network/

    I note you left off the trailing slash, see if that makes a difference.

    Also try loading http://iyta.org/wp-admin/network.php and see if you get the same message.

    It looks like your server is trying to parse the folder name as a php file.

  11. ingenuity
    Member
    Posted 4 years ago #

    I'm lost. Ipstenu, when I upgraded from 3.0, I just did the automatic upgrade.

    This is the code in the wp-config.php (with the DB password replaced with {snip}):

    <?php
    /**
     * The base configurations of the WordPress.
     *
     **************************************************************************
     * Do not try to create this file manually. Read the README.txt and run the
     * web installer.
     **************************************************************************
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'SNIP');
    
    /** MySQL database username */
    define('DB_USER', 'SNIP');
    
    /** MySQL database password */
    define('DB_PASSWORD', '{snip}');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'no');
    #$base = '/~iytaorg/';
    $base = '/';
    #define('DOMAIN_CURRENT_SITE', '66.147.240.198' );
    define('DOMAIN_CURRENT_SITE', 'iyta.org' );
    #define('PATH_CURRENT_SITE', '/~iytaorg/' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169 */
    //define( "EDIT_ANY_USER", true );
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    [CUT]
    {snip}
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', '');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    
    /* That's all, stop editing! Happy blogging. */
    define( 'NONCE_SALT', {snip}
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Andrea_p, with and without the slash and going to the URL you suggested, http://iyta.org/wp-admin/network.php, takes me to http://iyta.org/wp-admin/network/setup.php and that displays the message, "The Network creation panel is not for WordPress MU networks."

    Thanks everyone for your help!

  12. DO NOT POST YOUR AUTH KEYS AND SALTS IN PUBLIC PLACES

    Please stop doing that, people!

    I would STRONGLY urge you to go to http://api.wordpress.org/secret-key/1.1/wpmu/salt and get new one ASAFP.

    Also, please don't post your database user ID. It's just ... no sense in advertising.

  13. And we didn't need to see your cinfig file, because that;s not the problem.

    in my post above, I said your server is trying to parse the network admin area as a php file.

    takes me to http://iyta.org/wp-admin/network/setup.php and that displays the message, "The Network creation panel is not for WordPress MU networks."

    And THIS is correct.

    but this part:
    http://iyta.org/wp-admin/network redirecting you to basically http://iyta.org/wp-admin/network/setup.php is the issue.

    I told you to try that URL to see if you got that error message and you DID. that tells us what is wrong.

    It is your server. PLEASE talk to your host.

  14. ingenuity
    Member
    Posted 4 years ago #

    Eeks! I was very foolish to post the Config. I'm wiser than that now. Thanks for the warning. I changed the salt code and the database password. Now, andrea_r, I'll get on the phone with the host and report the problem you helped me identify. Will report progress. Thank you!

  15. ingenuity
    Member
    Posted 4 years ago #

    Well, after an hour on the phone with hostmonster.com, the host did not help. They said I would need to post a support ticket. I'm going to do that, but was told it would be a couple of days until I should expect a reply. Seems like I am stuck.

    I suspect that this is a legacy of having originally installed WPMU before WP3.0 came out. I wonder if I should somehow save my site and the custom plugins that were added to it and do a fresh install of WP and then set up the site again. That seems like a drastic measure.

  16. It woudl make the message go away, but I doubt it'd fix the actual issue.

    in other words, if you went to a fresh install, you'd see the network setup page instead of the index of the network admin.

    Seriously? They tell you to file a support ticket and they'll get aroudn to it in a couple DAYS?

    this is not a good host.

  17. ingenuity
    Member
    Posted 4 years ago #

    This problem has inexplicably resolved:

    I clicking the nag warning, "Thank you for Updating! Please visit the Update Network page to update all your sites." In the past, when I click on Update Network link, I got this error:
    The Network creation panel is not for WordPress MU networks.

    I also got the same error if I click on Network Admin from the upper right corner of the dashboard.

    But things have changed. The link now goes to:

    Warning! WordPress encrypts users cookies, but you must add the following line of code to wp-config.php for it to be more secure. Before the line /*That's all, stop blogging! */ please add this code:
    define( 'NONCE_KEY', 'REDACTEDFFS!' );

    Once I followed those instructions, the nag went away and it gave me the option to update the network. I did so and all has been functioning well since. I don't know why anything changed, but am happy it did.

    I followed the directions to add the line of code to wp-config.php file. the refreshed the WP-admin page and the message about encrypting user cookies went away I tried the Update Network and it worked!

    And now the link in the upper right to Network Admin works. :-)

    And after doing all noted above, I looked at the plugins and most of them looked like they needed to be Network Activated, so I did so with the plugins I knew we were using.

    I think it all is functioning well now. This is a very welcome surprise!

  18. Damnit! I said it in this thread!

    DO NOT POST YOUR AUTH KEYS AND SALTS IN PUBLIC PLACES

    That means your NONCE KEY too!

    Okay, you're probably okay, since that's one of 7 keys, but damn it, stop that. They're as important as your password to a hacker.

  19. ingenuity
    Member
    Posted 4 years ago #

    Ipsenu, you did warn me but I didn't realize that all keys were to be kept private. Ack! I was just trying to be responsible and report on how the problem was resolved. And now the forum will no longer let me edit or remove the post. I'm glad you say I am probably ok, but I will heed your warning and hide all my keys in the future. Thank you.

  20. I edited your post for you.

  21. ingenuity
    Member
    Posted 4 years ago #

    Thank you!! I'll know better in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic