Support » Plugin: Map Plugin alternative to Google Maps using MapQuest, with directions » The map does not appear in free version

  • Resolved sirtak

    (@sirtak)


    Hello,
    I need your support for something.
    I have installed this app, and I have inserted in one my post this shortcode: [get-directions latlng=”40.748021,-73.98512″ controls=”false”]
    That is precisely what I saw in the instructions of the plugin. Unfortunately – it does not work. It shows an empty white field. I got the API, from the page of the plugin with registrations.
    How can I fix this, shall I insert Google API key?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Fullworks

    (@fullworks)

    Hi,

    From what I can see in your post your shortcode has open speech marks, not quotes, WordPress does not like that.

    The first thing I suggest you do is retype the shortcode manually, using single quotes or double quotes, and let me know how you get in.

    The plugin does work, and has nothing to do with Google API keys.

    Alan

    Thanks for the answer, but unfortunately again it does not work. I only see a white field.
    I tried the both variants
    1) [get-directions latlng=”40.748021,-73.98512″ controls=”false”]
    2)[get-directions latlng=’40.748021,-73.98512′ controls=’false’]
    How can I fix it?
    They are no speech marks when I write here, but I don’t know why, when I save the text here, they are becoming speech marks.

    • This reply was modified 11 months, 2 weeks ago by sirtak.
    • This reply was modified 11 months, 2 weeks ago by sirtak.
    Plugin Author Fullworks

    (@fullworks)

    They do become speech mark when you put it in the wordpress forum – it is awful for changing things

    I have taken your shortcode – as above replaced the speech marks and added it to my test system and it works perfectly

    [get-directions latlng='40.748021,-73.98512' controls='false']

    If you can’t get it working using this then there is a local issue with your system – there are many moving parts – from incorrect API keys – to plugin or theme javascript conflicts to hosting php versions so the nextstep would be for you to debug systematically.

    The first step to take would be to check your browser console for javascript errors – any API issue would be clear in the error messages, see https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/ if you are unfamiliar with basic checking for errors

    Ok, thanks for the support, I will try to make these tests, so to find where the problem is.
    Best regards

    Hi again
    I gave to another person to make these test because I am not able to make it ( that is the firm for the hosting). He made a couple of checks, and according to him somewhere in the console, there was a message:
    Uncaught TypeError: Cannot set property ‘key’ of undefined at window.onload

    I changed the API key, and I tried with the new one – and again there was no result – just empty field.
    I tried with another domain (because the mentioned above was subdomain) and again there is an empty field.
    Now I saw, that when I prepare a new API key, there is a field – “Callback URL”
    What must write there – the page, where I intend to have the map with directions?
    What is the issue that “Consumer secret” is used for?

    Plugin Author Fullworks

    (@fullworks)

    You don’t need to put anything in the Callback URL, it is not used by the plugin.

    Is it possible to send you somewhere my API keys, and tell me are they working? I have already tested 5 API, and no one of them gives me results.

    Plugin Author Fullworks

    (@fullworks)

    I don’t know anywhere that provides testing of MapQuest API keys, you could try the MapQuest Developer Forums.

    And as mentioned, using the browser console will show you any errors.

    I am giving up for the moment, it is too complicated. As I wrote above – in the console there is a message:
    Uncaught TypeError: Cannot set property ‘key’ of undefined at window.onload
    Maybe there are many reasons for this – except for “Mapquest”, I am using also and “Google Maps Easy”. It is working with API directly from Google and there are no problems.
    Maybe Google API and MAPQUEST API are in conflict – I don’t know and will try to find an answer with these forums further when I have enough knowledge about these issues.
    Best regards.

    Plugin Author Fullworks

    (@fullworks)

    I haven’t heard back.I assume you either moved on or worked it out.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘The map does not appear in free version’ is closed to new replies.