Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » The links in my website will become IP address

  • Resolved stevetsai046

    (@stevetsai046)


    As topic, and I can’t find out the reason to cause this happen.
    There are some points, I think are related with this issue
    1. My wordpress management show my website address as IP address before, and after disconnect and reconnect, the website address show normal on my wordpress management.
    2. I’m using WP Fastest Cache, when the issue happened, I login to clean all cache and then the issue gone.
    3. The issue often happen when first time link to my website (open browser>type my web address>then it happen)

    Please help to provide some suggestion to fix this issue, thanks a lot!

    https://wordpress.org/plugins/jetpack/

Viewing 16 replies (of 16 total)
  • Attempting to fix this via .htaccess is generally bad advice + will cause all manner of breakage, if there are multiple virtual hosts on this IP…

    If this advice works at all… which it shouldn’t, because Apache is listening on your IP, not WordPress. If the above advice…

    RewriteCond %{HTTP_HOST} ^52\.38\.102\.113

    has any effect on your site, likely your hosting is seriously screwed up. This should have no effect, because the .htaccess being accessed is likely the default Webpage .htaccess which likely lives somewhere like /var/www/html or similar.

    You should contact your hosting provider to assist you correctly setting up your Apache config, which will likely have two stanzas… of the form…

    <VirtualHost *:80>
    … … …
    </VirtualHost>

    <IfModule mod_ssl.c>

    <VirtualHost *:443>
    … … …
    </VirtualHost>

    </IfModule>

    imac> dig +short stevehctsai.net a
    52.38.102.113

    imac> dig +short http://www.stevehctsai.net a
    stevehctsai.net.
    52.38.102.113

    Shows correct IP plumbing, so this is a Apache config issue.

    curl -I -L 52.38.102.113 – hangs forever, so it appears there’s now Webserver running on port 80.

    curl -I -L 52.38.102.113:443 – hangs forever, so it appears there’s now Webserver running on port 443.

    Your site appears also to be hosted by Amazon (horrific shudders…) so you’ll have to open a support ticket with Amazon… which will likely be ignored or replied to in a useless fashion.

    Likely best to move to any other Hosting Company. Avoid Amazon + Rackspace + WPEngine. They’re all expensive + have poor support.

    I find tech people at Hostgator + Bluehost tend to be more technically competent + services are far cheaper.

Viewing 16 replies (of 16 total)
  • The topic ‘The links in my website will become IP address’ is closed to new replies.