Support » Plugin: iThemes Security (formerly Better WP Security) » The link you followed has expired

  • After updating from version 7.6.1 to the latest 7.7.1, I get this error message when I am trying to access the plugin:

    The link you followed has expired. Please try again.

    This error message appears only when I try to access the “Settings” and “Security Check” tab.
    The “logs” tab is accessible.
    “Security Admin Messages” is also displayed properly at the top in the black WordPress admin bar.

    I have tried the following:
    – Deactivate and reactivate the iThemes Security plugin
    – Deactivate other plugins
    – Increase the file upload size, PHP memory, and execution time limits for my website (https://www.wpbeginner.com/wp-tutorials/how-to-fix-the-link-you-followed-has-expired-error-in-wordpress/)

    I have also reverted back to version 7.6.1 and got the same error message on the said two tabs.

    I’m running out of ideas. Can anyone help? Much thanks!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi,

    I have the same exact issue.

    Tried to deactivate the plugin. Uninstalled the plugin and cleared database and reinstalled the plugin but no change.

    Only logs page is accessible. Please advise.

    Try and add the line below to the wp-config.php file:

    define('ITSEC_DEBUG', true);

    This will add an extra Debug submenu option to the main Security menu.

    Post the info from the System Info section on the Debug page. Don’t forget to obscure/anonymize any info you don’t want to share.

    To prevent any confusion, I’m not iThemes.

    • This reply was modified 1 year, 4 months ago by nlpro.

    Thank you @nlpro

    Here is the System Info from the Debug page.

    ### Site Info ###
    Site URL: https://domain.com
    Home URL: https://domain.com
    Multisite: No

    ### WordPress Configuration ###
    Version: 5.4.2
    Language: en_US
    Permalink: /%postname%/
    Theme: FocusBlog 1.416
    Show on Front: page
    Page On Front: Home (#12249)
    Page For Posts: Unset
    ABSPATH: /home/user/domains/domain.com/public_html/
    Table Prefix: Length: 5 Status: Acceptable
    WP_DEBUG: Disabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    Object Cache: No
    Memory Limit: 40M

    ### iThemes Security ###
    Build: 4118
    Pro:
    Modules: ban-users, backup, brute-force, network-brute-force, and wordpress-tweaks
    Cron: 1
    Cron Status: 1
    Scheduler: ITSEC_Scheduler_Cron
    Features:

    ### Active Plugins ###
    Advanced Custom Fields: 5.8.12
    CheetahO Image Optimizer: 1.4.4
    CSS Hero: 4.11
    Duplicator: 1.3.34
    Give – Donation Plugin: 2.6.3
    iThemes Security: 7.7.1
    ManageWP – Worker: 4.9.6
    MemberPress Plus: 1.8.11
    Official Facebook Pixel: 2.0.2
    Page Links To: 3.3.3
    Permalink Manager Lite: 2.2.8.6
    Posts in Page: 1.4.4
    Redirection: 4.8
    Schema Pro: 2.0.1
    Search & Filter: 1.2.12
    Shortcodes Ultimate: 5.9.0
    Subscribers.com: 1.5.1
    Supercast: 1.3.1
    Thrive Apprentice: 2.2.16
    Thrive Architect: 2.5.5
    Thrive Clever Widgets: 1.54
    Thrive Comments: 1.4.3
    Thrive Headline Optimizer: 1.2.7
    Thrive Leads: 2.2.16
    Thrive Optimize: 1.4.1
    Thrive Ovation: 2.3.2
    Thrive Quiz Builder: 2.2.16
    Thrive Ultimatum: 2.2.15
    WP-Optimize – Clean, Compress, Cache: 3.1.2
    WP Testimonials with rotator widget: 2.4.3
    YellowPencil Pro: 7.3.1
    Yoast SEO: 14.3

    ### MU Plugins ###
    ManageWP – Worker Loader:

    ### Webserver Configuration ###
    PHP Version: 7.3.17
    MySQL Version: 5.5.5
    Use MySQLi: Yes
    Webserver Info: litespeed
    Host: DBH/localhost, SRV/domain.com

    ### PHP Configuration ###
    Safe Mode: Disabled
    Memory Limit: 256M
    Upload Max Size: 32M
    Post Max Size: 32M
    Upload Max Filesize: 32M
    Time Limit: 60
    Max Input Vars: 1000
    Display Errors: N/A

    ### PHP Extensions ###
    cURL: Supported
    fsockopen: Supported
    SOAP Client: Not Installed
    Suhosin: Not Installed

    JulieMarie

    (@juliemarie)

    Same issue for me too. I deactivated Pro, activated this one and the problem persists. I cannot access the settings.

    The link you followed has expired.

    nlpro

    (@nlpro)

    So you are hitting this issue in both the Pro and free release ?

    And it did work in the past in the Pro release?

    Probably best to follow the instructions I left in a previous post in this topic. Sharing some details of your setup helps the community help you 😉

    To prevent any confusion, I’m not iThemes.

    Try this. In wp-content/plugins/better-wp-security/core/admin-pages/page-settings.php at line #45:

    if ( ! empty( $_POST ) && ( ! defined( 'DOING_AJAX' ) || ! DOING_AJAX ) ) {

    …replace with:

    if ( ! empty( $_POST['itsec-nonce'] ) && ( ! defined( 'DOING_AJAX' ) || ! DOING_AJAX ) ) {

    Then retry and let us know the result.

    Note this is not a permanent solution. Just need your feedback. If it works I’ll contact the plugin developer and request the fix above to be included in the next release.

    Unfortunately, it didn’t change anything. I am still unable to adjust settings because “The link you followed has expired.” Thank you so much for trying though.

    Thank you, I really appreciate your feedback.

    Hmm, in another identical topic I received confirmation that it definately fixed the very same issue. I’m pretty confident (99.999999%) it should fix the issue in your env too. I’m not guessing. Did my homework, before coming up with this solution. Perhaps (Cloudflare) caching is preventing the fix from getting effectuated.

    One thing is for sure, it’s a plugin conflict. You could try and temporarily deactivate all plugins except iThemes Security. That should make the Settings page work again. Then activate the other plugins one by one and keep testing the Settings page.
    This way you should be able to identify the conflicting plugin.

    The more plugins your site is using the higher the chances this particular plugin conflict will occur.

    Please share the list of active plugins in your site. This will help identify plugins that are shared on sites that run into the same issue.

    In the other topic it turned out to be the plugin named:

    Ultimate Addons for Elementor (This is a paid for premium plugin).

    The first plugin I tried disabling was Ultimate Addons for Elementor and it resolved the issue without having to update line 45 as previously suggested. Thank you so much for your assistance!

    Ah, here you go. Please deactivate (and delete) any plugins you don’t need. Keeps your WordPress site healthy;-)

    Just out of curiosity, was this a purchased Ultimate Addons for Elementor plugin ? Or was it unofficial ?

    If the latter, don’t install and run unofficial plugins 😉

    The plugin “WordPress hosting benchmarking tool” created the conflict with iThemes Security for us. Got “The link you followed has expired”. We deactivated the benchmarking tool, and itsec now works again.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘The link you followed has expired’ is closed to new replies.