Support » Plugin: Wordfence Security - Firewall & Malware Scan » The last rules update for the Wordfence Web Application Firewall was unsuccessfu

  • Resolved Revived

    (@revived)


    The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was…

    I keep seeing that error and dismissing it only works temporarily. What’s the fix?

Viewing 12 replies - 31 through 42 (of 42 total)
  • This is NOT resolved. I am running the very latest version (7.4.6) and am encountering this. My wflogs/rules.php file has proper write permissions.

    Getting this message: “The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was January 26, 2020 4:09 pm, so this site may be missing new rules added since then. You may wait for the next automatic attempt at February 21, 2020 8:06 pm or try to Manually Update by clicking the “Manually Refresh Rules” button below the Rules list.”

    There is no “Manually Refresh Rules” button anywhere in the Wordfence UI. In fact, there is not even a Rules list. The “Manually Updated” bit links to /wp-admin/network/admin.php?page=WordfenceWAF&subpage=waf_options#wf-option-wafRules, and that page has nothing that says “Manually Refresh Rules”. Seriously frustrating. Ready to pull the plug on this plugin..

    Recently had this too but was an easy fix. All i did was restore defaults then it asked to download htaccess after I did that the notice went away.

    Same problem here. I’m deactivating and deleting the plugin. Cant be arsed to wait for a solution.

    I am still getting this message “The last rules update for the Wordfence Web Application Firewall was unsuccessful.” Please let me know if there is a fix for this issue.

    We all keep seeing this and failing to resolve it.

    HELP!!

    asplash

    (@asplash)

    I just cannot get the rules to update or the message to disappear. This is becoming unworkable. Is there somewhere I can get a copy of the latest rules and put them in place myself until this is resolved?

    Hi.

    We have been wrestling with this same issue. We manage our servers through Hostwinds, and have multiple boxes. We recently upgraded an older box to support PHP 7.3…and all the 7.3 sites on that box started throwing the same “Wordfence Rules” error, so I knew it was server settings specific (at least it was for me). Found out that PHP-FPM was disabled. I re-enabled PHP-FPM for 7.3, and resolved the issue on all sites on that box instantly. Hope that helps.

    Addition to above comment…I DID have to manually refresh the rules to note success. (which had failed for me every time prior)

    I have refreshed the rules more than once, keep getting this error. Looks like a common issue.

    I am also having this issue suddenly on multiple sites (different physical servers/IPs).

    The WordFence diagnostics “Connectivity” area tells me that everything is connecting fine.

    Can we get someone to look into this?

    I am having this issue as well, the latest rule refresh was on April 23rd.

    I have tried de- and reactivating the plugin, as described earlier in this thread. No success.

    I have tried manually updating the rules, no success.

    I have deleted the rules.php file (after backing it up), but Wordfence only generates an empty file in its place.

    There are no errors related to WF in any way in my debug log.

    I am running Wordfence 7.4.7 on WordPress 5.4.1.

    Rafael

    I had that problem some time ago, and it was some option on the server PHP version. I print the wordfence errors (on diagnostic) to my host and the fix-it changing something on the PHP (I do not remember what was).

    But try to change the PHP version on your panel and see if that fix the problem.

Viewing 12 replies - 31 through 42 (of 42 total)
  • You must be logged in to reply to this topic.