Support » Plugin: Wordfence Security - Firewall & Malware Scan » The last rules update for the Wordfence Web Application Firewall was unsuccessfu

  • Resolved Revived

    (@revived)


    The last rules update for the Wordfence Web Application Firewall was unsuccessful. The last successful update check was…

    I keep seeing that error and dismissing it only works temporarily. What’s the fix?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Recieved an answer from support:

    For the rules update issue, our latest plugin release improved reporting so that the plugin will notify you if it can’t finish the WAF rule update process. However, in most cases we’ve found that the WAF rules are actually being updated, but a second part of the process that downloads malware signatures doesn’t always complete, and are working on a solution to be released in the near future – in the meanwhile, it’s likely that the rules are being updated, but you can check this by looking at the timestamp on wp-content/wflogs/rules.php – if the “last modified” timestamp on the file is the last time you updated the rules, then the rules are up to date. Note that the malware signatures are also separately download by the scanner so this should not affect scanning performance.

    Perhaps they can also solve the issue where clicking “manually update” does nothing, or am I the only one that has that problem? Can’t dismiss the error, can’t update the rules manually, aargh 🙁

    UPDATE: just discovered that deactivating and re-activating clears the notice.

    I have the same problem. @nosilver4u what do you mean by de- and reactivating? The firewall or the plugin wordfence itself? both doesn´t work for me.

    @aarontrom I meant the plugin itself. I had messed with dismissing the notice, and clicking the manual update link, and got frustrated and deactivated Wordfence.
    Then after I found this thread, and has posted my comment, I re-enabled it, and the notice was gone.

    @nosilver4u okay thanks, i tried the same as you did, but the notice doesn´t disappear… however, i will wait for updates 🙂

    I have the same problem… I got the notice in the wordpress panel and updated manually… more than 1 week ago… now I jump again that March 15 did not update the rules… I just put by filezilla in wp-content / wflogs / rules.php and I see that the file was updated on March 19. It only happens in 1 of my 7 webs I wait for the update because it’s quite annoying… Acabo de intentar actualizar manualmente y me aparece… “Rule Update Failed
    No rules were updated. Please verify you have permissions to write to the /wp-content/wflogs directory”.

    I just checked other websites and I also get the message in some … the strangest thing is that in some can update manually and in others not … gives me the error message above …

    thanks

    • This reply was modified 7 months, 3 weeks ago by  elevas33.
    • This reply was modified 7 months, 3 weeks ago by  elevas33.

    i have the same issue. this notification does not disappear.
    i also changed directory wp-content/wflogs permissions and rules.php file to 777
    but it is not updating anything when i try to update manually then it is showing “Rule Update Failed” dialog box and message is “No rules were updated. Please verify you have permission to write to the wp-content/wflogs directory.”

    Plugin Support wfdave

    (@wfdave)

    We released an update that should have fixed this yesterday.

    Can you make sure you have the last update (7.2.4) and manually updating the rules?

    If that doesn’t work can you try deleting the rules.php file in wp-content/wflogs?

    Let Wordfence automatically regenerate the file (usually within 30 minutes) and see if the issue is resolved.

    Thanks!

    Dave

    I deleted the rules.php a few hours ago. A new file was generated, but it is empty.

    Running latest updates of WF and WP

    Dave

    I deleted rules.php as well with the latest update installed and mine is blank too. I still click on manual update and it doesn’t work 🙁

    Never had issues before and this error is on both of my sites (hosted on the same server via nginx)

    any ideas @wfdave ? I’m on the verge of removing wordfence after all these years to try another plugin…would rather not but I’m also sitting here now with no rules and defunct firewall 🙁 thanx in advance

    1. I’ve completely deleted and reinstalled wordfence via wordpress “add new plugin”, reactivated premium key.
    2. I’ve deleted the rules file in my wp-content/wflogs/rule.php, I let wordfence repropagate file, tried to manualy update rules, got error about not connecting to servers. my rules were empty so I copied from most recent backup of rules.php for time being to be safe.
    3 I’m updated to latest Version 7.2.4

    I have done the same (copied over a backup copy of rule.php since it was blank). I’ve deactivate and re-activated to no avail. I will be removing it for the time being to try out alternatives until there is (hopefully) a solution to this.

    We are experiencing the same problems and lack of action. Also removing and deleting the plugin and looking for replacement.

    I’m having the same issue now with at least a dozen clients’ sites, on different webhosts from godaddy managed wordpress, to dreamhost, hostgator etc.

    All the sites are running the latest WP core and the latest Wordfence, and i’ve tried all the fixes noted above, deleting rules.php, deleting and re-installing Wordfence etc, and no luck at all with any of them.

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.