Support » Plugin: Translate Multilingual sites - TranslatePress » The language page is a one, big link

  • When going to the language page, even before any translation I can see the page is just a huge, one link. Every text is flashing as a link (blueish), every white space is a link and they all lead to the lanugage home page.

    How can I fix this?

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Denis

    (@sdenis)

    Hello,

    Could you please show this to us with a short video showing the problem ?
    You can use a free software like:
    http://www.loom.com

    This will help me debug this further.

    Kind regards,

    Thread Starter gregbialowas

    (@gregbialowas)

    Hello,

    I really don’t know what else could I show you, that is not obvious on a page itself.
    Example, the home page works fine, your plugin does an AMAZING job, no links (apart from those that should be there): http://leancoaching.eu/dev/en/

    When you go to this subpage: http://leancoaching.eu/dev/pl/o-nas/ the site looks as it should look like. Changing the language version, though, turns the page into a one huge link: http://leancoaching.eu/dev/en/o-nas/.

    I removed the plugin, deleted connected tables in the DB and install it again, with NO translations whatsoever and nagivated to the o-nas page. Same happened, the site was turned into a one, big link.

    This one is okay:
    http://leancoaching.eu/dev/en/obszary-wsparcia/

    This one is a one, big link:
    http://leancoaching.eu/dev/en/oferta/

    There no translations on neither of the last two pages.

    Thank you!

    Kind regards,
    Greg Bialowas

    Plugin Support Denis

    (@sdenis)

    Hello Greg,

    I’m sorry, the first time I accessed the page I didn’t notice what you mentioned.

    Since this looks a lot like a conflict with some other code, the first/next recommended step is the conflict test (ideally in a staging environment):

    ​​*Briefly* disable all other plugins and enable the default Twenty Twenty theme. Please also disable all add-ons. If this fixes the problem, as it probably will, enable everything one by one, checking each time to see when the problem returns.

    Please let us know when you find the conflict so that we can take a look and see what we can do about it.

    Kind regards,

    Thread Starter gregbialowas

    (@gregbialowas)

    Hello,

    I removed (disbled) pretty much every single plugin exept for the Elementor.
    The problem remains.

    When you access translated page, eg. http://leancoaching.eu/dev/en/o-nas/ the whole site is a one big link that leads to Home page.

    Same with this page – http://leancoaching.eu/dev/en/oferta/ – every paragraph is a link that leads to the Home page, every single paragraph.

    There are NO links in a code itself, it is added by the TranslatePress plugin, for egzample:

    < a href=” http://leancoaching.eu/dev/en/ ” title=” Time line by Ohno ” data – no – translation – title >

    Whenever I click a left mouse, by accident, I am immediately taken to the Home page.
    Only buttons have links, obviously, but not paragraphs, images, or quotes, yet this link to Home page is added everywhere on the translated (or about to be translated) subpage.

    How can I disable that link?

    Kind regards,
    Greg Bialowas

    • This reply was modified 2 years, 2 months ago by gregbialowas.
    • This reply was modified 2 years, 2 months ago by gregbialowas.
    Thread Starter gregbialowas

    (@gregbialowas)

    Hello,

    I have noticed one thing:
    sometimes there are more than just From X -> To Y.
    There are From original -> To X (title atribute) -> To Y.

    In those cases everything on the page IS a LINK.
    When there’s only X to Y, everything works perfectly.

    Could you tell me what did I wrong (if I did) and how to fix this?

    Thank you.

    Plese see attached screenshot for reference.
    Screenshot – translation turned the page into one big link

    Kind regards,
    Greg Bialowas

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The language page is a one, big link’ is closed to new replies.