Support » Plugin: TinyMCE Advanced » The lack of admin rights breaks the tags.

  • Hello. Do not judge strictly my English, this is not my native language.

    The problem occurs when someone who does not have administrator rights tries to use some formatting functions, such as bottom underscore or color text.
    As you can see in the screenshots, everything seems to be correct.
    Original message
    Original message HTML

    But after sending a message on the forum is displayed incorrectly. Having opened the editing of the message, you can see that in the HTML-view the symbol “<” is replaced by “& lt;”, and the symbol “>” by “& gt;”.
    Incorrect message
    Incorrect message HTML

    If you perform similar actions with an account that has administrator rights, then such an error does not occur.

    What could be the problem?

    I humbly wait for your help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • temon137

    (@temon137)

    Found a solution to the problem.
    It turned out that not all roles of the forum were allowed to use HTML formatting. Fix it using the plugin User Role Editor: needed roles just need to give permission “unfiltered_html” from paragraph “General”.

    Permissions

    Plugin Author Andrew Ozz

    (@azaozz)

    WordPress Dev

    …the symbol < is replaced by & lt;, and the symbol > by & gt;.

    I believe this is for security reasons. It is dangerous to allow posting of HTML for non-trusted users. It is a really bad idea to do that for “All” users.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘The lack of admin rights breaks the tags.’ is closed to new replies.