Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » The Jetpack server was unable to communicate with your site [HTTP 500]

  • Resolved JigmeDatse


    When trying to connect Jetpack I am getting the following error:

    The Jetpack server was unable to communicate with your site [HTTP 500]

    I haven’t found anything clearly pointing to *what* might be the issue. Reading the logs I see: – – [20/Sep/2016:10:43:31 -0700] “POST /xmlrpc.php?for=jetpack HTTP/1.1” 500 215 “” “Jetpack by”

    in the access.log when trying to connect Jetpack, and:

    [Tue Sep 20 10:43:31.776209 2016] [:error] [pid 24770] [client] PHP Fatal error: Uncaught Error: Call to undefined function xml_parser_create() in /var/www/openpsychology/wp-includes/class-IXR.php:264\nStack trace:\n#0 /var/www/openpsychology/wp-includes/class-IXR.php(464): IXR_Message->parse()\n#1 /var/www/openpsychology/wp-includes/class-IXR.php(432): IXR_Server->serve(‘<?xml version=”…’)\n#2 /var/www/openpsychology/wp-includes/class-IXR.php(440): IXR_Server->__construct(Array, false, false)\n#3 /var/www/openpsychology/wp-includes/class-wp-xmlrpc-server.php(197): IXR_Server->IXR_Server(Array)\n#4 /var/www/openpsychology/xmlrpc.php(84): wp_xmlrpc_server->serve_request()\n#5 {main}\n thrown in /var/www/openpsychology/wp-includes/class-IXR.php on line 264, referer:

    in the error.log.

    Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Ryan C.


    Can you contact your hosting provider and explain to them that we are unable to access your blog via cURL, which is needed in order to use Jetpack on your site?

    You can let them know we tested the following:

    1. Check for access to xmlrpc.php via browser:

    That test returned “XML-RPC server accepts POST requests only.” which is a valid result.

    2. Check for access via cURL by running the following command from the command prompt:
    curl -i -H 'Content-Type: text/xml' --data '<?xml version="1.0&"?><methodCall><methodName>demo.sayHello</methodName><params></params></methodCall>' ''

    The cURL test returned the following invalid result:

    HTTP/1.0 500 Internal Server Error
    Date: Fri, 23 Sep 2016 22:15:33 GMT

    Please provide the information above to your hosting provider so that they can correct the server settings to allow cURL access.

    Let me know how that works for you, and we can go from there!

    Thread Starter JigmeDatse


    I think I got it working now. I seem to be having an odd week in terms of breaking (but managing to fix them) things over and over (different things, so far not broken the same thing…) Thank you.

    For future people coming to this page, my error was because the php7.0-xml package was not installed on my server.

    Plugin Contributor Ryan C.


    Thanks for the update, and I’m glad to hear that you were able to get this issue resolved!

    @jaredmcateer – Many thanks for your note – that was exactly the issue I was having. Just upgraded Ubuntu from 14.04 to 16.04 w/PHP7, and the php-xml library wasn’t installed.

    Hi Im getting the sam problem,

    Can anyone help with this please ?

    Error Details: The Jetpack server was unable to communicate with your site [IXR -32300: transport error: http_request_failed cURL error 28: Connection timed out after 10001 milliseconds]

    Plugin Author Jeremy Herve


    Jetpack Mechanic 🚀

    @wellmanweb Your issue is quite different from the one reported above.

    Can you please use Jetpack’s Debugger module to send us some more information about your site?

    1. Go to the Jetpack page in your dashboard.
    2. Click on the Debug link appearing at the bottom of the page.
    3. Click the link that says “click here to contact Jetpack support.”
    4. Fill in the description box and your name and email address.
    5. Click the “Contact Support” button to send us the debug results privately. It’s best not to post this information on public forums, as it contains private details about your site.


Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘The Jetpack server was unable to communicate with your site [HTTP 500]’ is closed to new replies.