WordPress.org

Support

Support » Plugins and Hacks » [Resolved] The Images of Tiles seems following the thumbnail size of the default

[Resolved] The Images of Tiles seems following the thumbnail size of the default

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mike Martel

    @mike_cowobo

    Hi Timo, I just uploaded version 0.2 of WP Tiles with a lot of improvements. You can now use the wp-tiles-image-size filter to return the desired image size. For example:

    add_filter('wp-tiles-image-size', 'change_tile_image_size');
    function change_tile_image_size( $image_size ) {
        return 'large';
    }

    Drop this in your functions.php and the tile backgrounds will be the desired image size!

    You are ROCK mike !!! this plugin is totally awesome. The best plugin i ever had for WP. Bravo. I Upgrade the version and everything solved.

    You are ROCK mike !!! this plugin is totally awesome. The best plugin i ever had for WP. Bravo. I Upgrade the version and everything solved.

    Hello Mike. Thanks for making this great plugin 😀

    I’m not so savvy about editing files but I gave it a good attempt. I added the above php to the functions file and then, added the example code from

    http://codex.wordpress.org/Function_Reference/add_image_size

    to be sure I had a valid size name. At this point I get a message saying

    Fatal error: Cannot redeclare change_tile_image_size() (previously declared in /home/content/92/9751992/html/wp-content/themes/responsive/functions.php:29) in /home/content/92/9751992/html/wp-content/plugins/wp-tiles/wp-tiles.php on line 165

    (I know I should use a child theme)

    I really have no idea what to do now hahaha.

    BTW This is my first post ever! What I’m trying to do is set the height so I can contain the tiles in a div.

    Plugin Author Mike Martel

    @mike_cowobo

    Hi Svybiral, welcome to the WordPress forums! The error you’re getting is because you can’t declare (define) a function with the same name twice.

    It seems like you have also edited the files of the tiles plugin (wp-tiles.php doesn’t have a function change_tile_image_size() normally). So your first step would be to uninstall and reinstall WP Tiles, to make sure the plugin is right.

    Then, add the function and the add_filter code from my post above to your functions.php. Make sure you replace ‘large’ by the image size you added earlier with add_image_size().

    Good luck and do let me know here if it doesn’t work out.

    Mike

    Hi Mike.

    After following your instructions I ran into a problem with the new (post) gallery tiles. The new tiles were super low quality. I went threw a bunch of trial and error to fix it. In the process I reset pretty much EVERYTHING to default. In the end the problem was resolved by using a plugin that forces thumbnails to regenerate. The new tiles are nice and crisp now 🙂

    I never did get the image size function to work though but I’d prefer to just leave it be. I think whatever isn’t working is probably user error. Anyway, now I’m using a 100% width layout and it looks nice and functions perfectly.

    Sorry for the trouble and thanks again for your great plugin.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] The Images of Tiles seems following the thumbnail size of the default’ is closed to new replies.