Support » Plugin: BackWPup - WordPress Backup Plugin » The HTTP response test get a false http status (404)

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Daniel Hüsken

    (@danielhuesken)

    It can be that your Hoster not allews the acsses.

    Hello,

    I’m having the same problem. I am using iThemes Security, which offers the following options.

    1. ENABLED
    Remove File Writing Permissions
    Prevents scripts and users from being able to write to the wp-config.php file and .htaccess file. Note that in the case of this and many plugins this can be overcome however it still does make the files more secure. Turning this on will set the UNIX file permissions to 0444 on these files and turning it off will set the permissions to 0664.

    2. ENABLED
    Disable File Editor
    Disables the file editor for plugins and themes requiring users to have access to the file system to modify files. Once activated you will need to manually edit theme and other files using a tool other than WordPress.

    3. NOT ENABLED (But I’d like to enable it if possible)
    Protect System Files
    Prevent public access to readme.html, readme.txt, wp-config.php, install.php, wp-includes, and .htaccess. These files can give away important information on your site and serve no purpose to the public once WordPress has been successfully installed.

    Any suggestions for me?

    Thanks!

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    That has nothing to to with file permissions. BackWPup must can call http://…./wp-cron.php as a normel http request (like a webbrowser it does). It can be the some plugins add rules that this normel acsses not works. Did scheduled posts work on your site?

    Yes, scheduled posts were working, but stopped on February 8th.

    I’ve tried deleting my saved job, and created a new job, but neither scheduled or manual backups will work.

    I think I’ve received the same error as both and 404 and 403.

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Scheduled post and BackWPup uses both the wp-cron.php. Test a scheduled post in future. If it not works you have a genneral problem with wp-cron.php. I think if you resove you generl problem with wp cron than backWPup will working to. Soory, but i can’t resolve it for free and i must have full acsses to you blog.

    Had the same problem. BettonDesign`s tip worked great for me as well. Thanks a lot!!
    adding the following line to wp-config.php file;

    define(‘ALTERNATE_WP_CRON’, true);

    I can access wp-cron.php on my site, it displays a blank page with no errors, and I verified the file is there and accessible through FTP.

    BettonDesign’s solution is the one that worked for me!

    jpm1234

    (@jpm1234)

    Does a normal manual backup require the use of wp-cron.php?

    Here was the situation where I received the error and how I fixed it:
    – Testing a remote VPS hosted wordpress install with DNS not pointing yet to the wordpress VPS server’s ip address.
    – Local hosts file was modified to point to the correct ip address.
    (eg. 107.x.y.z websitetotest.com)
    – Attempted to run a backup job manually on the remote test wordpress VPS server.

    I was testing the VPS hosted site using a local hosts file modification, which directed the webbrowser to the correct ip address for the websitetotest.com website. The DNS settings for the website were not pointed to the correct ip address yet, as the site was not yet live.

    The remote site was working fine in the browser, but was giving a “The HTTP response test get a false http status (404)” error when trying to start the BackWPup job.

    I realized that it was running the HTTP test request from the VPS server side which has no idea where websitetotest.com was setup (due to DNS not being setup yet).

    After modifying the VPS server’s hosts file as well to include the correct entry, the remote VPS was able to locate the domain name correctly.

    This fixed the 404 error, so starting the job manually worked correctly afterwards.

    I’m not sure if this is an edge case that you want to consider handling in the plugin, but I thought I would post what I did to fix my issue in case anyone else has this problem.

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘The HTTP response test get a false http status (404)’ is closed to new replies.