Support » Plugin: WP YouTube Lyte » The HTML code changes depending on the user agent.

  • Resolved cck23

    (@cck23)


    Thank you for a great plugin.
    I’m suffering from structured data errors in the search console.
    I’m informing you that I’ve been investigating and found some mysterious behavior.
    The HTML code rendered by the user agent has changed, although it may interfere with other plug-ins.

    UserAgent=PC
    <div class=”lyte-wrapper fourthree” …><div class=”lyte lP”><div><meta itemprop=”thumbnailUrl”…>…

    UserAgent=SmartPhone
    <div class=”lyte-wrapper fourthree” …><div class=”lyMe” …><iframe …>…

    Do you have any idea?

    • This topic was modified 1 year, 7 months ago by cck23.
    • This topic was modified 1 year, 7 months ago by cck23.
    • This topic was modified 1 year, 7 months ago by cck23.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    that probably is because LYTE by default does not show the LYTE player on mobile to prevent the user having to click “play” twice (because autoplay does not work on mobile). You can force LYTE on mobile by ticking the “cache thumbnails locally” optoin or with this simple code-snippet;

    add_filter( 'lyte_do_mobile', '__return_true' );

    hope this helps,
    frank

    Thread Starter cck23

    (@cck23)

    Thank you for your quick support.

    As I told you, I tried enabling thumbnail cache.
    Sure, the same HTML code is available on mobile!

    You are the best man!

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    Thread Starter cck23

    (@cck23)

    I deleted the post because I made a mistake. sorry.

    • This reply was modified 1 year, 6 months ago by cck23.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘The HTML code changes depending on the user agent.’ is closed to new replies.