WordPress.org

Support

Support » Plugins and Hacks » WPtouch Mobile Plugin » [Resolved] The Home Page does not show mobile version

[Resolved] The Home Page does not show mobile version

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author BraveNewCode Inc.

    @bravenewcode

    Hi Brian,

    It looks like you need to configure W3 Total Cache to ignore WPtouch’s mobile user agent list. Please add the list of user agents below to the “Page Cache”, “Minify” and “CDN” settings. Then, clear all caches.

    iphone
    ipod
    ipad
    pre
    pixi
    iemobile
    aspen
    incognito
    webmate
    android
    dream
    cupcake
    froyo
    blackberry9500
    blackberry9520
    blackberry9530
    blackberry9550
    blackberry 9800
    blackberry 9780
    blackberry 9850
    blackberry 9860
    webos
    s8000
    bada
    googlebot-mobile
    adsbot-google

    Hello!
    I have one quick question and this post was the most related one I could find.
    I have the exact same problem as Brian, but I don’t have W3 Total Cache installed.
    However, since my website is still under construction, I kept it in a subfolder (example.com/subfolder/) and I thought that may be causing the problem, because whenever I try to reach any other page that isn’t the home page, I can see it. Could it be?
    Thank you very much! Great looking plugin… Can’t wait to get it working!

    soret, I think this may be related. I have the same problem and the same conditions as you. Anyone has the idea on how to fix this?

    It makes sense, but my website is in a subfolder because it’s a new unpublished version of the one in the root folder and it is intended to be there in the future, once it’s ready to be published. It’s just too soon (not finished) to publish it yet, and either way I can’t publish it without being sure what’s causing this problem… And to make sure I need someone to clear it out for me before I either purchase the Pro version, or publish the site…

    I have the same issue with my site. Desktop version is fine. Using elegant themes lean biz I get 404 when I try to go to home page on mobile but all other pages work beautifully. . Please help!

    I do not have any cache plugins installed

    My problem was actually kind of silly… In WPTouch settings, there is a part that says “Home Page Redirection” or something like that. For some reason, I changed the settings to redirect it to the desktop homepage, causing an infinite loop. I don’t know why or when I did that. Perhaps because I thought the default setting was doing the opposite of what it was doing, I don’t know. It was just a matter of setting that option to “WordPress Settings” and voila, fixed!

    Plugin Author BraveNewCode Inc.

    @bravenewcode

    @ouguitarman, it sounds as if your issue is different than a caching problem or a home page redirection loop. Because WPtouch uses the same urls that your desktop theme uses (except in the one instance where you set a new mobile homepage), you’ll want to check your other active plugins and .htaccess file for any type of redirection that may be overriding WPtouch.

    Plugin Author BraveNewCode Inc.

    @bravenewcode

    Glad we were able to help.

    Hello, I have a similar issue for our mobile version. I have installed the WP Touch plugin by Brave new code and we can’t get our landing page to be the home page.

    In our dashboard, our pages does not have a ‘homepage’ because it was hard coded in the Main Index Template.(index.php)

    Could someone please help our business leverage the WPTouch mobile plugin correctly where we can select our homepage as the landing page when you first visit the site. Any guidance would be greatly appreciated.

    Site: http://www.newhorizonfhs.org/

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] The Home Page does not show mobile version’ is closed to new replies.
Skip to toolbar