Support » Plugin: Best Image Gallery & Responsive Photo Gallery - FooGallery » “The gallery was not found” after host migration

  • Resolved rfmurphy81

    (@rfmurphy81)


    Hi there,
    I am migrating one of my sites from a shared host over to Cloudways and running into an issue where the FooGallery plugin doesn’t seem to work as expected.

    Prior to migration/on the original site, everything works great. Used the Cloudways migrator plugin to copy over the site content and databases. On their temporary URL (https://wordpress-123456-1234567.cloudwaysapps.com), the galleries work as expected (there’s a browser ERR_CERT_COMMON_NAME_INVALID error that can be ignored as the site seems to load as expected).

    However, when I switch my A record in Cloudflare DNS over to the new IP address and define the permanent domain in the Cloudways domain management page under the WordPress application, I’m constantly seeing “The gallery was not found” where the shortcode is being used.

    I saw another post referencing the same error but it seemed to indicate a database problem, which I don’t believe to be the case here. Is there somewhere else I should be looking to resolve this issue? I’m wondering if it’s related to whatever database change the Cloudways domain management page does when I enter the domain (rather than leaving it deleted so it uses the default temp domain).

    Any suggestions for where I should look?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support fooplugins-support

    (@influxfooplugins)

    Hi @rfmurphy81,

    It seems the issue is related to the URL configuration in the migration process and not Foogallery because the galleries exist and work on the test domain.

    I have done further research on the issue. The permanent domain could be missing in some of the WordPress settings. Could you try asking your Cloudways hosting provider to backup your database and try to update your permanent domain in the database as described in the article at https://wpbeaches.com/updating-wordpress-mysql-database-after-moving-to-a-new-url/? Furthermore, they should also check the paths to the galleries when the page is loaded in the PHP error logs in order to determine if their settings are pointing to the correct domain as compared to the test domain.

    You can also have a look at the plugin documentation: https://fooplugins.com/documentation/foogallery/troubleshooting-foogallery/exporting-importing-galleries/ on how to export galleries from a previous website/installation and import them to your new website/installation.

    N/B: Make sure you have backup your website and databases before trying the above troubleshooting steps so that you can revert changes made to the database and website in case you encounter any problem.

    If you have any other questions, do not hesitate to ask.

    Kind regards,
    Blaise.

    Thread Starter rfmurphy81

    (@rfmurphy81)

    Thanks for the reply. I had actually noticed it wasn’t happening for me when browser the site in incognito/private mode so it seems to only be happening when I’m logged in as admin. I’m also noticing some other things with caching and their recommended caching plugin, Breeze, so at least this isn’t affecting the users browsing the site. Based on this update, do you think the recommendation in the previous post should still be pursued or should I look down a different avenue? Thanks again!

    Plugin Support fooplugins-support

    (@influxfooplugins)

    Hi @rfmurphy81,

    If it works on the front end, it should be able to display on your admin page. Have you also tried clearing your WordPress cache then testing on a browser using a different device? Kindly also check if there is a plugin conflict. You can use the health check plugin to easily check for a plugin conflict. For more information on using the health check plugin, please visit: https://fooplugins.com/documentation/general/general-troubleshooting/health-check-debug/

    Let me know how this goes.

    Kind regards,
    Blaise.

    Plugin Support elviiso

    (@elviiso)

    Hi @rfmurphy81

    First, as we mentioned earlier and based on your previous message to us, this issue is definitely not caused by FooGallery.

    With that said, you mention that the issue does not happen when you browse the site in an incognito browser, and from this it does sound like a cache issue from your end and this issue is most likely not happening to your site’s visitors.

    I’d advise you to start by clearing the caching plugin installed in your site, and in your case, the cache of the browser you’ve been using.

    You can also pursue the earlier recommendation we had given you.

    Thanks.

    Kind regards,
    Elvis

    Plugin Support elviiso

    (@elviiso)

    Hi @rfmurphy81

    We haven’t heard from you in a while, so we presume the problem has been resolved and we’re closing this support ticket.

    If you are still experiencing the problem, then please open a new support ticket.

    Regards,
    Elvis.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.