Support » Plugin: Gwolle Guestbook » The form can’t be sent, error message persists

  • Hi Marcel,

    After updating the plugin, the following problem occured.
    There are those fields configured in the form, all mandatory: Name, Text, Anti-Spam custom question.
    When trying to send the form, the following error persists: “You haven’t entered the name while it is mandatory” + “You haven’t entered the correct answer to anti-spam question while it is mandatory”. Of course the name and correct anti-spam answer are being entered.
    The problem dissapeared after AJAX in the form was disabled.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Marcel Pol

    (@mpol)

    Yes, I don’t understand what is happening. For some reason the field values don’t get sent when AJAX is used. It only happens on some websites and maybe some browsers.

    Plugin Author Marcel Pol

    (@mpol)

    Hi zhonglyor,

    Would you be willing to try the current development version with AJAX enabled? I might have a fix for this, but I am not sure.

    If you are willing to try that out, please go to:
    https://wordpress.org/plugins/gwolle-gb/advanced/
    and download the development version of the plugin.
    Then enable AJAX for the form, and see if this update fixes the sending of all the form data.

    Thread Starter zhonglyor

    (@zhonglyor)

    Hi Marcel,

    Sorry for the delay with my answer. I see the topic being marked as resolved. Unfortunately it’s actually not.

    I’ve just tried the development version. Still the same error when AJAX in the form is ON. So I’ve switched it OFF again.

    In fact, it’s OK for me to have the form without AJAX. Thus you may leave it as is 🙂

    Plugin Author Marcel Pol

    (@mpol)

    Thank you for your reply.
    I think that is quite annoying 🙂 It was fixed for someone else, but apparently not for your website.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘The form can’t be sent, error message persists’ is closed to new replies.