Support » Plugin: W3 Total Cache » “The following requests are returning 404/410 responses” in the GTmetrix test

  • Resolved galena

    (@galenashop)


    Hello,
    In the gtmetrix test I have the same “bad requests”:
    The following requests are returning 404/410 responses. Either fix the broken links, or remove the references to the non-existent resources.

    /wp-content/cache/minify/c7035.js?x97182
    /wp-content/cache/minify/e8294.js?x97182
    /wp-content/cache/minify/fcb12.js?x97182

    I think it started after trying the minify settings, but I deactivated it and cleared all caches. It only appears on the shop page, everything is ok on the main page.

    It is the similar problem that is described in this topic: https://wordpress.org/support/topic/w3tc-non-existent-js-and-css-in-cache-minify-throw-errors/page/
    but removing all .htaccess files from the wp-content/cache directory, what is recommended here, does not work.

    Can you help me with that?
    Thank you
    Alena

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @galenashop

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Yes, I can see those errors in the console on the mentioned page.
    I’ve tried adding the random query string to the end of the URL https://www.galena-shop.cz/obchod/?Agsfdgh which is removing the cache, and if you visit the page with the query string you will notice that the error is gone so this means that those files are cached.
    I am not sure if you are using any other caching solution like server-side caching but the solution is to purge all caches. (check if there is a wp-content/cache/minify/ folder and delete the /minify/ folder manually.
    I can also see that you are using Nginx reverse proxy so possibly the cache is also stuck there.
    I hope this helps!
    Thanks!

    Thread Starter galena

    (@galenashop)

    I manually deleted the wp-content/cache/minify/folder and no server-side caching solution is used. Any another ideas?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @galenashop

    Thank you for the information.
    Have you tried purging all cache? Please delete the wp-content/cache/page_enhanced
    Also as I mentioned you are using Nginx reverse proxy. Please check if it needs to be purged.
    Also, you should possibly try to completely remove W3 Total Cache and see if the issue persists and if not re-install it again:
    1. Purge Cache
    2. Deactivate and Delete Plugin
    3. Check .htaccess File (make backup)
    W3TC will create many directives in .htaccess file to control the caching behavior. Each section will start and end with comments like “#BEGIN W3TC Page Cache core” and “#END W3TC Page Cache core”.
    Ensure that no residual entries are left over in your .htaccess file after deleting the plugin.
    4. Delete wp-content files and folders
    – cache folder (since you are using AO, only delete the folders related to W3 Total Cache like page_enhanced and db folder)
    – w3tc-config folder
    – object-cache.php (if exists)
    – advanced-cache.php (if exists)
    – dbcache.php (if exists)
    – upgrade folder
    – delete w3-total-cache folder in wp-content (if exists)
    5. Delete Cached Files from CDN (if using CDN)
    Besides deleting all the relevant files, if you use CDN then ensure to purge the cached content from your CDN. This is necessary when you enabled the minify option in W3TC settings. You should delete the minified and combined scripts and CSS files from your CDN server to avoid the site breaking on the browser.
    6. Go to your wp dashboard and re-install W3 Total Cache

    Thanks!

    Thread Starter galena

    (@galenashop)

    Hello Marco,
    Thank you for your help. I manually deleted the wp-content/cache/page_enhanced folder and it solved my issue.
    Thanks Alena

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @galenashop

    Thank you for the information.
    I am glad to know the issue is resolved!
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“The following requests are returning 404/410 responses” in the GTmetrix test’ is closed to new replies.