Support » Plugin: Calculated Fields Form » The final step at the top of the page

  • Resolved altkmv


    Hello there!

    I almost finished the calculator of training programs. Everything works as it should, but at the last step I have several voluminous fields at once and the page opens at the very bottom. Tell me how you can get to the results page and be at the top

    Thanks for your time.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author codepeople


    Hello @altkmv,

    Could you clear you browser’s cache and test again, please? and if the issue persists, could you indicate the browser you are using?

    I’ve tested your form with different browsers, and the window is scrolled at beginning of form in the last page as should.

    Best regards.

    Tried, it did not help. I went to page of 2 browsers: chrome and firefox.

    See, when you get to the page, you need to make a choice and click the Next button. So you will go to the second page. And so on. On 5 of 6 pages, mark a few points and go to the last page. You will be at the bottom of the table, not at the top of the page. Even if you do not select items on page 5, you are still at the bottom of the table.

    PS: tell me, today I added the last 10-12 text fields and after that the page load has grown noticeably. Is this a local problem or is it really really slow?

    Plugin Author codepeople


    Hello @altkmv,

    I’m sorry, but I’m testing from my side and this is not happening, I see you are using a plugin to manage your website’s cache, so, you can be using a cached version of the js files.

    However, an alternative would be insert a “HTML Content” field in the form with the following piece of code as its content:

    jQuery(document).on('mouseup','.pbNext', function(){
    jQuery('html, body').animate({scrollTop: 0}, 50);

    Concerning to the form performance. There are some issues in your form.

    First, the equations. I’ll try to describe how the plugin works.

    If the form was configured to evaluate the equations dynamically, everytime that you vary the value of a field in the form, the plugin should check all the equations associated to the calculated fields to determine which of them are affected by this field, and evaluate them, and then, it checks if there are equations that are affected by the values of the calculated fields that were calculated, and evaluate them, and so on.

    Your current form has 251 fields and from them, 151 are calculated fields, so, it is required check and maybe evaluate 151 equations at once (at least when the form is loaded all the equations are evaluated)

    My recommendation. Please, think if you really need 151 calculated fields, and optimize their equations. An alternative would be disable the dynamic evaluation of the equations and insert a button the users should press to evaluate the equations.

    For this, go to the “Form Settings” tab and untick the checkbox: “Eval dynamically the equations associated to the calculated fields” (, and then, insert a button field in the form, and select as its type the “Calculate” option.

    Second issue, your form is loading 12 images that are no optimized for their width and height in the form or the screen’s quality, the size average of these images’ files is 300k, so, your form is adding to the page, only with these images, around 3MB extra. Please, optimize the images.

    Best regards.

    • This reply was modified 1 year, 11 months ago by codepeople.
    Plugin Author codepeople


    Hello @altkmv,

    Please, create a ticket in my private website:

    Because, for some reason WordPress has classified my answer to be checked by a moderator.

    Best regards.

    Thanks, I create theme on that site in others questions

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The final step at the top of the page’ is closed to new replies.