Support » Plugin: Beautiful taxonomy filters » The filter not filtering

  • Resolved freyaindexel

    (@freyaindexel)


    Hello,

    I add this plugin to my local website.
    The filter display very well my category taxonomy but when I select one and click on the button “filter” my list of post not filtering. Did I miss something ?

    (I add this in my archive-{custom_post}.php
    <?php do_action(‘show_beautiful_filters_info’); ?>
    <?php do_action(‘show_beautiful_filters’); ?>)

    Thank you

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jonathandejong

    (@jonathandejong)

    Hi Freya,

    Do you perhaps have some other plugin (or your theme) that modifies the post lists of your custom post type?

    BTF uses WordPress core filtering but adds the pretty URL rewrite rules on top of those. So if you end up on the correct URL but the post list is not filtered I’m guessing there is something else messing with the query 🙂

    freyaindexel

    (@freyaindexel)

    Hello thanks for reply
    But it still doesent work :/

    I have a custom post “projet” and 2 taxonomy (“levier” & “region”).

    I have my “archive-projet.php” with the following code :
    <?php do_action(‘show_beautiful_filters_info’); ?>
    <?php do_action(‘show_beautiful_filters’); ?>

    and my query :

    <div class="wrapper list-project">
    		<ul class="flex">
    			<?php
    				$args_projet = array(
    					'post_type' => array('projet'),
    					'order' => 'ASC',
    				);
    	
    				$projet = new WP_Query( $args_projet );
    	
    				if ( $projet->have_posts() ) {
    					while ( $projet->have_posts() ) {
    						$projet->the_post(); 
    	
    						get_template_part( 'template-parts/content', 'part-projet' );
    	
    					}
    				} 
    				else {}
    	
    				wp_reset_postdata();
    	
    			?>
    		</ul>
    	</div> 

    and as I said when i click on the submit button I have the pretty url, the infos of the filter are correct but there is still all the post in the list. Nothing seems to interfere with the list, maybe there is something mithing in the basic file of wordpress ? I realy dont know how to figured out whith this issue.

    Thanks a lot

    freyaindexel

    (@freyaindexel)

    Ho I just find out !
    The archive does not like the parameter post-type because is already know this info !

    It work !!

    solved !

    • This reply was modified 2 months, 4 weeks ago by freyaindexel.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.