Support » Plugin: Themify - WooCommerce Product Filter » The filter changes the layout of the Divi shop module

  • jpnl

    (@jpnl)


    Hi, can you please have a look at this page that is created with the Divi theme?

    The products are listed with the Divi Shop Module in a 4 column layout on desktop. Problem is that as soon as you apply a filter, it turns into a 4 column layout.

    To test, go to the linked page and apply the filter [Kleur ยป Rood].
    This results in 4 productes, but instead of showing them in a 4-column layout, they are shown in a 3-column layout.

    Thanks
    JP

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author themifyme

    (@themifyme)

    This is related to Divi Shop module: https://wordpress.org/support/topic/divi-shop-module-issues/

    We’ve released the latest version to address the problem. It should be working with the latest version now.

    Hi, version 1.2.3 doesn’t fix the issue I described in my original post. Can you have a look again please?

    Thanks
    JP

    Plugin Author themifyme

    (@themifyme)

    @jpnl It seems to be fine on our demo: https://themify.me/demo/testdemo/divi/product-filter/

    Also, if you apply another filter, it is fine: https://share.getcloudapp.com/jkunqn4Z. The issue seems to be related to “Kleur > Rood” only.

    What about your Customize > WooCommerce setting?

    Hi,

    You can’t compare your demo with mine. You can’t reproduce it in your demo because it has a 2 column layout. The problem is that a 4 column layout changes to 3 columns after filtering.

    The other difference is that you have the filter in the sidebar and I have it on top.

    It’s not only with kleur=red, all other filters cause the change to a 3 column layout. Try:
    – kleur=zwart (results in 2 product in 3 columns, not 4) or
    – tag=test or
    – stijl=gesmoord or
    – stijl=vormbak or
    – fabrikant-aberson

    Thanks
    JP

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.