Support » Plugin: Feed Them Social - for Twitter feed, Youtube, Pinterest and more » The feed instagram does not work

  • Resolved solucionesweb2142

    (@solucionesweb2142)


    Hello, the feed instagram of our websites has stopped working. I have tried to use the button to connect with the social network in the plugin but it does not work (it is the first time it happens).
    Maybe it is for using the API that instagram has disabled (it seems that yesterday, June 29) https://www.instagram.com/developer/
    Is this why the error? Is there a way to fix it? If not, are you preparing an update to fix the problem?

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • solucionesweb2142

    (@solucionesweb2142)

    I add that on our part no changes have been made to the website, plugin or instagram account settings.
    I add below the error code when pressing the button “Login and get my Access Token” in the Instagram options of plugin:
    {“error_type”: “OAuthException”, “code”: 400, “error_message”: “Invalid scope field (s): basic, public_content”}

    Thank you.

    Plugin Contributor slickchris

    (@slickchris)

    Hi @solucionesweb2142,

    Yes Instagram has depreciated their “Legacy API”. In order to display your Instagram feed, through our plugin, you will need to re-acquire a new access token.

    But first, please delete Slick Remix from your IG account. You will need to be logged into your or your client’s Instagram account. From your desktop, go to your Instagram profile, click the gear icon, then click “Apps and Websites”, then click “Remove” for Feed Them Social by Slick Remix (then click ‘remove’ again if prompted).

    Now go back to your WordPress dashboard, under the Feed Them > Instagram Options page in our plugin and click the button to get a new access token (and follow the prompts).

    Even if you receive an error message, scroll down and click the green ‘Save All Changes’ button. Then go to the Feed Them > Settings page to generate your shortcode, apply the new shortcode to your page and, after you update/publish, you may need to clear the FTS cache for the new changes to take effect.

    Panda in Camo

    (@pandaincamo)

    Hi Guys,

    Exact same issue from my side. I removed the items from Instagram, then reset the key. I then Clicked the sign-in button “Sign-in with Instagram” and the browser goes to a white screen with the below error.

    {"error_type": "OAuthException", "code": 400, "error_message": "Invalid scope field(s): basic"}

    Unable to progress the sign-in further, when I click back all I can do is try clicking the same sign-in button again. (ie it’s having a problem negotiating Oauth with Instagram).

    Kind Regards,
    Ben

    Plugin Contributor slickchris

    (@slickchris)

    Hi @pandaincamo,

    If you have tried the above steps and are still getting the error, make sure you are logged into your IG account before you try to gain your access token. And, please be sure you are running the latest FTS free version (currently 2.8.5).

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.