Support » Plugin: My Calendar » The event pop-up boxes won’t OPEN

  • Resolved Roger

    (@rogerwheatley)


    When using the calendar widget, event pop ups open without issue.

    When using the shortcode in a page [my_calendar] the calendar displays, but the events do not open when clicked.

    I observed that the visitor must click a category before a pop-up works.

    Is there a way to change this behaviour, so that users do not have to click a category before event pop-ups work?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Joe Dolson

    (@joedolson)

    Can you provide a URL? This is not the normal behavior, which suggests a JS issue on your site. However, I can’t be more specific without seeing what’s happening.

    Roger

    (@rogerwheatley)

    @joe Dolson Thanks, please see that happening here: Example Page (link will open in a new tab)

    Plugin Author Joe Dolson

    (@joedolson)

    You have a conflict with the Divi “smooth scroll” option. If you can disable that, you should be fine.

    Roger

    (@rogerwheatley)

    Thanks, smooth scroll was disabled (and still is) – Does not fix the issue.

    Sadly, still not working.

    If I manually click the category under the calendar, only then will it work.

    Is there any way to auto-select a category (instead of visitors manually clicking a category)?

    The calendar widget pop-ups work, just the “in-page” calendar (using shortcode) pop-ups still do not work.

    I notice that the pop-ups URLs for the widget are not the same as the pop-up URLs for the in-page calendar. (It looks like the in-page pop-ups are missing parts of the URL).

    Plugin Author Joe Dolson

    (@joedolson)

    Yes, you can certainly manually pre select a category, but that won’t solve the problem.

    The issue is that there is JS in Divi which is attaching a behavior to all links that begin with a ‘#’, including those used by My Calendar to trigger the details pop-ups.

    When you navigate the calendar using JS, the Divi actions aren’t re-attached to the links, so they only have the My Calendar behaviors.

    To complicate this, when Divi “disables” smooth scroll, it doesn’t get rid of the JS to execute it; it just attaches the code and disables it.

    You *can* get around this by setting up My Calendar to open calendar links to individual event pages instead of opening the pop-ups, in which case the links are no longer in-page links.

    Roger

    (@rogerwheatley)

    Thank you!
    One last question, please…

    Where is the setting for “…My Calendar to open calendar links to individual event pages instead of opening the pop-ups…”? I cannot seem to find it.

    Appreciated!

    Roger

    (@rogerwheatley)

    Oh, sorry, I finally found it! 🙂

    My Calendar >> Settings >> Output >> “Open calendar links to event details URL”

    Any fix for this yet? I also use Divi. A fix is needed badly. Thanks

    Plugin Author Joe Dolson

    (@joedolson)

    I strongly recommend reporting the issue to divi, in hopes they will eventually fix the problem.

    I reported this via their support, but are there any manual workarounds to overcome the JS issues in Divi?
    Could you be a little more specific about which JS does this? Perhaps it could be removed in a child theme for my site.

    Thanks!

    For me disabling the link allowed the popups to open normally. I used this css:

    /*calendar popupfix*/
    .my-calendar-table .event-title .url {
    pointer-events: none;
    }

    bonus to make the cursor turn to a hand over he areas that are clickable to make the popup show:

    .my-calendar-table .event-title{
    cursor:pointer;
    }

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘The event pop-up boxes won’t OPEN’ is closed to new replies.