Support » Plugin: Gutenberg » The editor has encountered an unexpected error. Attempt Recovery Copy Post Text

Viewing 15 replies - 1 through 15 (of 51 total)
  • Plugin Author Daniel Richards

    (@talldanwp)

    Hi @monica5,

    I did some searching and found this topic where others had experienced the same issue:
    https://wordpress.org/support/topic/wordpress-5-4-typeerror-cannot-read-property-dottip-of-undefined/

    You could try some of the steps mentioned there. If you have a caching plugin active, it could be worth trying to clear the cache of that plugin as well as your browser cache.

    Thread Starter monica5

    (@monica5)

    Hi Daniel, @talldanwp

    thanks. I’ve tried a lot of the suggested:
    – only caching plugin, SG Optimizer, manually purged cache. Browser cache also cleared
    – incognito mode didn’t help
    – rollback to Gutenberg 10.9.0 and 10.9.1 didn’t help
    – I have not updated WP recently
    – I do not use Autooptimize plugin
    – I’m using Yoast SEO (and don’t know what ACF that nikza mentioned stands for)
    – not using WP Cleaner
    – haven’t touched REST API keys
    – not using Cloudflare
    The suggested thread didn’t solve the issue unfortunately.

    Hosting company ran Google Chrome Console test, and can see many errors and these are all from the Guthember plugin itself:

    Error: Failed to execute 'removeChild' on 'Node': The node to be removed is not a child of this node. at Sh (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:152:165) at Qj (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:174:181) at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26) at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8) at eb (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:170:163) at gf (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:162:317) at https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:230 at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26) at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8) at $g (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:176)

    CAN A GUTENBERG FIX BE RELEASED PLEASE SO THAT THE BLOCK EDITOR WORKS SMOOTHLY AFTER THE ERROR DISAPPEARS?
    Many thanks…

    Thread Starter monica5

    (@monica5)

    Hi Daniel, @talldanwp

    thanks. I’ve tried a lot of the suggested:
    – only caching plugin, SG Optimizer, manually purged cache. Browser cache also cleared
    – incognito mode didn’t help
    – rollback to Gutenberg 10.9.0 and 10.9.1 didn’t help
    – I have not updated WP recently
    – I do not use Autooptimize plugin
    – I’m using Yoast SEO (and don’t know what ACF that nikza mentioned stands for)
    – not using WP Cleaner
    – haven’t touched REST API keys
    – not using Cloudflare
    The suggested thread didn’t solve the issue unfortunately.

    Hosting company ran Google Chrome Console test, and can see many errors and these are all from the Guthember plugin itself.

    CAN A GUTENBERG FIX BE RELEASED PLEASE SO THAT THE BLOCK EDITOR WORKS SMOOTHLY AFTER THE ERROR DISAPPEARS?

    Many thanks…

    Plugin Author Daniel Richards

    (@talldanwp)

    @monica5 Could you use the ‘Copy Error’ option and paste the result in a message here.

    I thought the error you were seeing is the one you linked to here (https://thomas.vanhoutte.be/miniblog/wordpress-fix-the-editor-has-encountered-an-unexpected-error/), but I see that’s a post from over a year ago. As such the cache clearing advice wouldn’t work.

    Please could you also not post in all caps.

    Thread Starter monica5

    (@monica5)

    Thank you @talldanwp – the error message is posted right above at https://wordpress.org/support/topic/the-editor-has-encountered-an-unexpected-error-attempt-recovery-copy-post-text-4/#post-14678756 (the forum moderators have to approve such a post manually).

    No, I’m not experiencing that dot problem you’re linking to. No clearing cache works, not even the server one.

    Error message follows in the next post below

    Thread Starter monica5

    (@monica5)

    I have merely substituted my site for a generic title @talldanwp
    Thank you.

    
    Error: Failed to execute 'removeChild' on 'Node': The node to be removed is not a child of this node.
        at Sh (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:152:165)
        at Qj (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:174:181)
        at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26)
        at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8)
        at eb (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:170:163)
        at gf (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:162:317)
        at https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:230
        at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26)
        at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8)
        at $g (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:176)
    • This reply was modified 1 year, 2 months ago by Yui.
    • This reply was modified 1 year, 2 months ago by Yui. Reason: formatting
    Plugin Author Daniel Richards

    (@talldanwp)

    @monica5 The error isn’t something I’ve come across recently.

    I’d recommend deactivating other plugins 1-by-1 to check whether any of them have an incompatibility.

    Thread Starter monica5

    (@monica5)

    @talldanwp thanks, but I’ve been using issue-free the same array of plugins for months, and I need them all for correct site functionality. Due to recent publishing and subscriber status changes, I can’t restore to latest fully functional date either. Doing so would disrupt my site I’m afraid. Again, I made no changes.
    I can provide you with a list of activated plugins (over email) so that you can see for yourself.
    The errors are exclusive to Gutenberg, editor with broad market penetration – it’s actually the plugin that released an update after which its functionality stopped working. In the meantime, I haven’t done any remarkable plugin update apart from Yoast SEO, SG Optimizer (the only caching plugin I use), and my hosting wasn’t able to initially recreate the problem on their end (they didn’t get the error), and suggested it’s a development issue. However, rollback to Gutenberg 10.9.0 or 10.9.1 haven’t helped.
    I cannot play around with working plugins, themes or child theme, I’m afraid.
    What resolution can there be please then?

    Thread Starter monica5

    (@monica5)

    @talldanwp I went once again through the list of all my active, installed plugins – deactivating those in the last 14 days updated ones, purging manually caches including the server ones, turning off everything Gutenberg related (Advanced editor tools, Ultimate addons for Gutenberg, Custom fonts), and I can say the problem isn’t related to plugins changes.
    What can you please suggest Daniel then?

    Thread Starter monica5

    (@monica5)

    @talldanwp I’m at the end of my wits. No matter if I flush caches each time I perform plugin deactivation, no matter Gutenberg ver 10.9.0 or 11.0.0, no matter the deactivations, or the only notification received (from Yoast to upgrade Gutenberg to 11.0.0), it has no effect. I run the latest Gutenberg 11.0.0 and also the latest WordPress ver, and the Gutenberg error is still there.
    Below, I’m including the Copy error contents:

    Thread Starter monica5

    (@monica5)

    
    Error: Failed to execute 'removeChild' on 'Node': The node to be removed is not a child of this node.
        at Sh (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:152:165)
        at Qj (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:174:181)
        at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26)
        at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8)
        at eb (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:170:163)
        at gf (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:162:317)
        at https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:230
        at unstable_runWithPriority (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react.min.755b0ae9.js:24:26)
        at Za (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:8)
        at $g (https://MYSITE.COM/wp-content/plugins/gutenberg/vendor/react-dom.min.edd8b7a6.js:73:176)
    
    • This reply was modified 1 year, 2 months ago by Yui.
    • This reply was modified 1 year, 2 months ago by Yui. Reason: formatting
    Thread Starter monica5

    (@monica5)

    Error message uploaded, I depend heavily upon you Daniel, thank you very much

    Plugin Author Daniel Richards

    (@talldanwp)

    I notice there are some similar forum users reporting issues:
    https://wordpress.org/search/Failed+to+execute+’removeChild’+on+’Node’

    A few with the google site kit plugin, not sure if that’s one you’re using?

    Thread Starter monica5

    (@monica5)

    Thank you @talldanwp but I’m not using Google site kit plugin, and haven’t adjusted JS for months – never on URLs other than homepage, and on homepage never preventing any JS from Gutenberg or similar from running. Again, last changes done to the homepage JS permissions was 6+ weeks ago, so this ain’t the source of the issue unfortunately.
    I’m not using fancy stuff on my site in the least – perhaps you could have a look at my wp-admin environment to see for yourself? Please, I would need this Gutenberg-centric issue resolved…

    Thread Starter monica5

    (@monica5)

    I have even tried whether the error would be recreated on a different, older Chrome browser, and it is. No amount of additional debugging and rollbacks is helping please.
    When is a fresh Gutenberg release planned for please btw @talldanwp
    Thanks, I would need to get it all operational please…

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘The editor has encountered an unexpected error. Attempt Recovery Copy Post Text’ is closed to new replies.