• good day, after updating to version 5.9, i am able to login the portal, but when I try to edit any of my website pages, the live website is still visible, but I cannot make any changes. I get this error:-
    “The editor has encountered an unexpected error – attempt recovery – copy post text – copy error”

    Here is the error-

    TypeError: Failed to execute 'appendChild' on 'Node': parameter 1 is not of type 'Node'.
        at se (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:21283)
        at ae (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:20218)
        at ge (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:21723)
        at he (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:22161)
        at x (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:33710)
        at L (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:34956)
        at https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:36207
        at https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:6078
        at A (https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:9347)
        at https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:9803

    end of error, can you assist, as this has never happened before after an update.

    • This topic was modified 2 years, 5 months ago by daz2022.
    • This topic was modified 2 years, 5 months ago by Jan Dembowski.
    • This topic was modified 2 years, 5 months ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • after updating to version 5.9

    Did the upgrade perform without issues?

    Thread Starter daz2022

    (@daz2022)

    Yes it all went well no issues reported after the update, I have cleared my browser history, cache etc. the reopened the admin module, I can see everything on the dashboard page, and on all other items, but when I click on the allpages link I can see the list of all the pages in my site but as soon as i click on the eidt link for any of the pages I get a blank page with the error:-
    `The editor has encountered an unexpected error.
    Attempt Recovery – link – this appears to do nothing
    Copy Post Text – link – this copies the post but not any of the images
    Copy Error` – link – this copies the errorihave pasted it below:-

    TypeError: Failed to execute 'appendChild' on 'Node': parameter 1 is not of type 'Node'.
        at se (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:21283)
        at ae (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:20218)
        at ge (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:21723)
        at he (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:22161)
        at x (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:33710)
        at L (https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:34956)
        at https://out-of-the-box.org/wp/wp-includes/js/dist/rich-text.min.js?ver=a3e3616311fad456179e52a7528ec7fd:2:36207
        at https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:6078
        at A (https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:9347)
        at https://out-of-the-box.org/wp/wp-includes/js/dist/compose.min.js?ver=058697a4c5024045c81954f411ff6dba:2:9803

    Any ideas?

    Unfortunately no solution, but I am having the same problem for some days now (maybe due to the WP Update to 5.9 some days ago):

    Things I found as possible solutions but that didn’t seem to solve the problem so far were:

    -updating browser
    -cleaning browser cache
    -cleaning wp cache
    -disactivating all installed plugins
    -using troubleshooting mode of site health plugin

    When Installing and selecting classic editor I can access my pages in classic editor. However when changing back to block editor the error re-appears.

    Any additional ideas?

    As I think this might be relevant: I am using twenty-twenty theme

    Thread Starter daz2022

    (@daz2022)

    We are using WEN associate Pro, we have also completed all the same things that you listed, and as yourself have had no luck.

    How were you able to change back to classic editor, I can’t see any options on my page when I select a page to edit, I can only see screen options at the top level where all my pages are listed

    Changing back to classic editor worked by downloading the “classic editor” plugin and the via settings -> writing -> Editor style

    I also think I figured out what my problem was/is.
    I am using images in some H1s of my pages (so the actual h1 is something like which WordPress 5.9’s block editor does not seem to allow (due to… reasons).
    I think I’ll hope for an update/patch and stick to the block editor so far as I do not want to change the entire site appearance due to this issue.
    Is this the same in your case? i.e., are you also having images as H1

    best

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘The editor has encountered an unexpected error’ is closed to new replies.