Support » Plugin: Yoast SEO » The editor has encountered an unexpected error.

  • Resolved luisa

    (@luisavilhena)


    Hello,
    I am having problems with Yoast Plugin.

    I am using WordPress 5.2.3 and Yoast 12.4 and my admin has this message “The editor has encountered an unexpected error” and my console have this message:

    “Block validation: Block validation failed because an error occurred while generating block content:

    TypeError: Object(…) is not a function”

    When I deactivate Yoast SEO 12.4 everything is working fine.

    Can anyboby help me with this issue?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support amboutwe

    (@amboutwe)

    We’re sorry that you are experiencing problems that might be caused by our plugin!

    Just to be sure, we would like to rule out any plugin or theme conflicts that may occur. The fastest way to do this is to deactivate all non-Yoast plugins and switch to a standard theme like Twenty Nineteen

    Test this on your development or staging site, if you have one. If not, we recommend using the Health Check & Troubleshooting plugin. This plugin allows you to run a conflict check without affecting normal visitors to your site.

    As we can imagine that you’re unfamiliar with checking for conflicts, we’d like to point you to a step-by-step guide that will walk you through the process: How to check for plugin conflicts.

    Same here. Classic editor is not working anymore like it should (missing buttons) after updating yoast to 12.4 (Premium).

    Also problems with the Yoast box in the post editor screen. Would like to rollback to 12.3. We have the Rollback plugin we aren’t able to rollback?! No rollback-link visible…

    How to downgrade to 12.3?

    Regards, Yuri

    Plugin Support Jerlyn

    (@jerparx)

    Hi @yuriv

    Premium (paid) products are not supported in these forums. For Yoast SEO Premium issues, please reach out to our Premium support through https://kb.yoast.com/kb/support/#premium.

    Thanks!

    A related problem. I have updated my wordpress and yoast seo plugin to the last version and I can’t use the plugin, it doesn’t charge and I can’t see the meta box.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @josfeal,

    We ask that you please create separate topics for the issues you are experiencing. That way it’s easier to track issues and provide assistance on your specific concerns on your specific site. Plus, you will get your own alerts for the issue rather than someone else’s. You may make a new topic here: https://wordpress.org/support/plugin/wordpress-seo/#new-post. Thanks!

    Thread Starter luisa

    (@luisavilhena)

    @amboutwe

    Thank you for all your help.
    I did step by step about How to check for plugin conflicts. and I realize that Yoast was conflicting with Advanced Custom Fields PRO plugin.

    What can I do? I need to send messages for Advanced Custom Field?

    Plugin Support amboutwe

    (@amboutwe)

    As it is a conflict with a Pro version of the plugin, we recommend contacting their pro support team for further assistance since pro versions (of any plugin) is not supported through these forums.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘The editor has encountered an unexpected error.’ is closed to new replies.