Support » Installing WordPress » The dynamic IP of host on which WP is running makes wp not work

  • I installed WP on my home host machine which is dynamic ip address. The problem is that when ISP changed the dynamic ip address and then I try to use the new ip address to connect WP, the first main page is ok. But if I try to click the other pages from the main page, it points to the link that contains the old ip address. Of course it fails. For example, I onece used an IP address and it worked: http://67.119.193.5/blog/index.php. After a while, the ip address have changed to 67.119.193.9. The I try http://67.119.193.9/blog/index.php. This page can show no problem, but when I tried to click another page link, i.e.About. It still tries http://67.119.193.5/blog/about. That is wrong. How to fix this problem and why does it happen? Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • What are the URI’s you’re using in Options:General?

    If you’re putting IP addresses into those Options -> General URIs and then the numbers change… well yeah, the wheels will fall off pretty quickly.

    Short version: Don’t put an IP address in there if it’s gonna be changing!

    Longer version: either name the machine and let other’s browsing to it know that name (local network? edit hosts files, WINS or DNS) or look into one of the Dynamic DNS services (google for dynamic DNS).

    I already used domain name with dyndns.org in Options -> General URIs. It seems that WP automatically translate it back to ip address and stored in mySql database. I just wonder how the guys who use dynamic ip solve this problem?

    well… no. that’s not what WP does! If you type in a proper domain name, WP does NOT convert that to IP and store it. Look in your db and you’ll see exactly what you typed in Options -> General.

    Are you running a dyndns client to keep the service updated with your current IP address?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘The dynamic IP of host on which WP is running makes wp not work’ is closed to new replies.