Support » Plugin: WP Super Cache » The dreded pages do not match ARGH!!!!

  • Resolved jlaks


    Installed wp super cache today. Getting away from W3 TC. For my own reasons (W3 while powerful, too much maintenance). Anyways, Installation of plugin went well. Was able to navigate settings fairly easily. And almost similar results to W3. Only problem when I test cache on admin page I am getting:
    Fetching to prime cache: OK

    Fetching first copy of OK (1.html)

    Fetching second copy of OK (2.html)

    The pages do not match! Timestamps differ or were not found!

    Now after some research this problem appears to affect a small handful of sites. Mine being one of them. I did as suggested to check timestamp in another browser. And guess what no timestamp. It looks like I am not getting a favorable result because there is no time stamp. Found a few articles on this with no real help.

    Hosting: Bluehost-Pro (shared service just a few less sites on server than standard plan).
    Server: Linux
    CMS: WordPress
    Cart Plugin: Woocommerce
    CDN: Cloudflare

    I tried the Debug option. And really nothing is jumping out at me. Some help with this would be much appreciated. I am pretty sure I am catching from the results I am receiving.

Viewing 13 replies - 1 through 13 (of 13 total)
  • WOW! It has been a week since I posted this support question. Nothing? I probably spend 20 minutes a day trying to research myself. A little help from creator would be nice. I know it’s free but a week? Don’t get me wrong I do love the plugin and what it is doing for my site. But I would like to get this nagging error corrected. Especially since it is only on one of my sites and the other 3 a perfect. The ones that are perfect same host and setup as problem child


    I can offer no help, but I am in the same situation. I have NO idea where/what the problem might be and looking around I find no solution.

    Below is an excerpt of what I see in the debug file. Any insight would beneficial. Is the plugin doing anything or shoudl I get rid of it and go back to W3 (which is way to complicated for my liking)?


    17:09:00 /?woo-layout-css=load&ver=3.5.1 Created output buffer
    17:09:00 /?woo-layout-css=load&ver=3.5.1 Output buffer callback
    17:09:00 /?woo-layout-css=load&ver=3.5.1 No closing html tag. Not caching.
    17:09:00 /?woo-layout-css=load&ver=3.5.1 wp_cache_shutdown_callback: collecting meta data.
    17:09:00 /?woo-layout-css=load&ver=3.5.1 Did not write meta file: wp-cache-68b95e207f6ff1e925fe879179c55daa.meta ** *0* **
    17:09:27 /cosa-trovi-in-questo-sito/ wp_cache_check_mobile:
    17:09:27 /cosa-trovi-in-questo-sito/ supercache dir: /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:27 /cosa-trovi-in-questo-sito/ No wp-cache file exists. Must generate a new one.
    17:09:27 /cosa-trovi-in-questo-sito/ In WP Cache Phase 2
    17:09:27 /cosa-trovi-in-questo-sito/ Setting up WordPress actions
    17:09:27 /cosa-trovi-in-questo-sito/ USER AGENT (Mozilla/5.0 (compatible; proximic; + rejected. Not Caching
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ wp_cache_check_mobile:
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ supercache dir: /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ No wp-cache file exists. Must generate a new one.
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ In WP Cache Phase 2
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ Setting up WordPress actions
    17:09:39 /mangiare-biologico-intervista-a-un-produttore/ Created output buffer
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Output buffer callback
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Anonymous user detected. Only creating Supercache file.
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ wp_cache_check_mobile:
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Gzipping buffer.
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Writing non-gzipped buffer to supercache file.
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Writing gzipped buffer to supercache file.
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Renamed temp supercache file to /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Renamed temp supercache gz file to /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Writing gzip content headers. Sending buffer to browser
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ wp_cache_shutdown_callback: collecting meta data.
    17:09:40 /mangiare-biologico-intervista-a-un-produttore/ Did not write meta file: wp-cache-bb6bd1b264e5ca6cd6dc542778b954fa.meta *1* *0* *1*
    17:09:45 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug wp_cache_get_cookies_values: /^wp-postpass|^comment_author_|^wordpress_logged_in_/ Cookie detected: wordpress_logged_in_07c7b97e255866821f929dd0b03326a7
    17:09:45 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug wp_cache_check_mobile:
    17:09:45 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug supercache dir: /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:45 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug No wp-cache file exists. Must generate a new one.
    17:09:46 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug wp_cache_get_cookies_values: /^wp-postpass|^comment_author_|^wordpress_logged_in_07c7b97e255866821f929dd0b03326a7/ Cookie detected: wordpress_logged_in_07c7b97e255866821f929dd0b03326a7
    17:09:46 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug In WP Cache Phase 2
    17:09:46 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug Setting up WordPress actions
    17:09:46 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug Not caching wp-admin requests.
    17:09:46 /wordpress/wp-admin/options-general.php?page=wpsupercache&tab=debug maybe_stop_gc: GC flag not found. GC will go ahead..
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 wp_cache_get_cookies_values: /^wp-postpass|^comment_author_|^wordpress_logged_in_/ Cookie detected: wordpress_logged_in_07c7b97e255866821f929dd0b03326a7
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 wp_cache_check_mobile:
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 supercache dir: /home/autosvez/public_html/wordpress/wp-content/cache/supercache/
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 No wp-cache file exists. Must generate a new one.
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 wp_cache_get_cookies_values: /^wp-postpass|^comment_author_|^wordpress_logged_in_07c7b97e255866821f929dd0b03326a7/ Cookie detected: wordpress_logged_in_07c7b97e255866821f929dd0b03326a7
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 In WP Cache Phase 2
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 Setting up WordPress actions
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 Supercache caching disabled. Only using wp-cache. Non empty GET request. Array
    [mcsf_action] => main_css
    [ver] => 3.5.1

    17:09:47 /?mcsf_action=main_css&ver=3.5.1 Created output buffer
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 Output buffer callback
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 No closing html tag. Not caching.
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 wp_cache_shutdown_callback: collecting meta data.
    17:09:47 /?mcsf_action=main_css&ver=3.5.1 Did not write meta file: wp-cache-123877198eec15baa917914dd0719271.meta ** *0* **

    Hi Arka,

    Thanks for posting here. I spend a little time each day trying to research this problem. And php is not my strong suite. But try to disable your plug ins one by one. Through my research you could have a plugin that doesn’t like Super Cache. This was not my problem though. I went through them and no help for me. Maybe it will help yours. I am disappointed there has not been any help yet from the author. I know he does get involved quite a bit from other post I have read. Would like his help for a minute. And I do agree way to much maintenance for W3. BTW are you using Cloudflare?

    php is not my strong suit either 😀 😀
    In any case, I have tried what you suggested and removed all the plugins (but Super Cache), but that made no difference.
    No, I am not using Cloudflare as yet (I have downloaded, but never got the time and the strength to read how it should work).

    I suspect that the “no not match” error is one of those things that could be caused by countless different things and it is not worth their while to waste time trying to troubleshoot it. Time will tell 🙂

    Hi arka1,

    The one thing I did not ask you. When you check your pages Timestamps do they match ( view page source html1, html2)? Because if they are there and match then pages are caching and plugin is working correctly. My problem is there is no Timestamps at the bottom of my pages. Something is stopping them to be added.

    A little help with this. Somebody, Anybody. It has been over two weeks since I posted first thread. Just hoping for plugin support team to at least point me in the right direction. I have read everything I could find on this problem. It is either that is the way it is or I am missing something. That is why I am here. For help. If you can’t get help at the support forum what good is it.

    And I thought someone had replied 😀 😀

    Anyway, I forgot to say that I do not have time stamps at all in the first place either 🙁

    Anyway, obviously VERY low priority for the developers… (or simply they don’t have a clue)

    Thanks arka. I am hoping for the plugin Author or part of his team or someone who could shed some light on this error for me. A few of the Author’s post’s on this I did find say this issue has been discussed many times. Unfortunately I find very little on this error. If he is talking about checking the timestamps well then maybe. But I don’t have any timestamps at all. Just three blank lines at the bottom of each page where the timestamps are supposed to be. I have checked de bug log various times and I can not find anything. HELP!!!

    After posting my own thread, I found this one. I have the same error, no timestamps. Not sure what it wrong.

    Hi My problem with the timestamps have been solved. I have been using Cloudflare for CDN. I was not making the connection that CF is using ngnix servers. Reason being my provider is Apache. I completely removed CF because of other problems I have been encountering with their service. And low and behold. Timestamps were their and matched. I hope this helps someone else with similar problems who have been using CF. just because your provider is using a friendly database to Super Cache if you are using CF it will be processed by their server which is ngnix which as the Author states can have issues.

    What do you know… it works now with me as well. No idea why. The only thing I have done is to install a couple of days ago Google PageSpeed. Yesterday I was going to delete SuperCache, but for some reason I run the test again, and lo and behold it worked.
    Don’t ask me why, because I don’t know.

    Anyway, Supercache guys, great support, thanks… 🙁

    Great! Works now! Must have been cloud flares services…

    Hi all,

    I found your thread and it’s one that is more recent.

    We’ve got a site that has two versions, one on our staging server and one on a production server (VPS). The caching works on staging (test comes back fine), but on production it does not work. I get the same issue you all had – no timestamps at all in the source to even check!

    I’m wondering if anyone else has come across this problem and solved it some other way? We do not have a CDN set up yet, so that is not what the problem is. All other plugins/settings are the same between the two WP installations (managed through Git).

    My guess is there’s some sort of setting that is/is not set on the production server that could be causing the problem? The production site was original on a shared server before being upgraded to a VPS and the caching did not work on the shared server either. These servers (except for staging) are with HostGator.

    Any ideas on what to check/look for would be great…


Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘The dreded pages do not match ARGH!!!!’ is closed to new replies.