WordPress.org

Support

Support » How-To and Troubleshooting » The Dreaded 404 Error for New Website

The Dreaded 404 Error for New Website

  • Hi guys! I had a lot of help from a previous question in the installation board but my troubles are an ongoing theme I guess.

    My problem is that my website http://www.prairiepariah.com is giving me the ol’ “404 Not Found” deal when I try to log into the wp-admin.php page.

    Yesterday I had my website working. After fighting forever with it for no apparent reason it started working and I was able to finally finish installing wordpress and get my website somewhat up and running (after four days of trying). All I got to do was change the header image and background colour in the customize setting and then bam, “404 Not Found” strikes again.

    I’m using DreamHost and FireFTP and everything seemed to be working just fine (for a few minutes anyways) until it randomly stopped working. Why would it do that?

    I put it temporarily to “park” yesterday and shortly after had this happen. I took it off park today. I’ve read some other pages on 404 errors and some people say that with DreamHost you need to be patient and just give it time to process. This happened yesterday and it’s still not working. Does DreamHost or WordPress always do this kind of thing? I’m thinking I must have done something wrong but I don’t know what.

    I’ve also been mindful on clearing cookies and deleting the cache, closing everything and restarting etc.

    I also read about some people needing to disable plugins (found here: http://perishablepress.com/quickly-disable-or-enable-all-wordpress-plugins-via-the-database/ ) although this confused me. Do I do this thought DreamHost or FireFTP or what? Do I even need to do this? I don’t know. I should have mentioned that I’m new at this.

    Sorry if this a tired problem, but a nagging one since there are a lot on the subject. I’ve browsed through them on the forum but it’s hard to tell since most problems seem unique to the individual. I would love your help because I don’t know where else to turn. I have no friends who understand websites and wasn’t taught this stuff in my design classes.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • It looks like your domain is parked.

    I’m sure DreamHost support can help you with this as well, but essentially a parked domain does not point to your web directory, which is why you’d get a 404.

    It needs to be “Fully Hosted” to show your site properly.

    To fix this, go to “Manage Domains” in the panel, and click “edit” next to your domain.

    Then, fill out the Fully Hosted section, and click “Fully Host this Domain”

    Hopefully this helps!

    Note that if you remove the parking altogether, you’ll need to click “add” to make the domain Fully Hosted, rather than clicking “edit”.

    If you run into trouble with this, I highly suggest contacting DreamHost support, here, since this is a hosting issue rather than a WordPress-centric one. =)
    https://panel.dreamhost.com/index.cgi?tree=support.msg&

    Thanks Mike! I’m going to look into that right now. I wasn’t sure if this was the result of a wordpress issue or DreamHost.

    For the future if anybody else is having this issue with DreamHost and you parked your website got to the “Welcome” section on the left side of your screen. There it will take you to some options, so go to where it says “Website Hosting”. This will show your domains and an “Edit” button should be under “Web Hosting”. When you’re in “Edit” it will show a list of options. Click on the blue button that says “Fully Host this Domain” (I think that’s what it says. Right now mine says “Change settings” because I already did this).

    Hmm, after doing this my website doesn’t seem to exist at all now… maybe I’m supposed to be a little more patient?

    I am seeing your blog at http://www.prairiepariah.com/blog/. Did you get this resolved?

    If you want it to be at http://www.prairiepariah.com/ then you would need to follow the instruction here:

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    No, the wp-admin.php link won’t bring me to the log in page. It just says “404 not found” so I’m close to giving up :\ I’m really disappointed that building my own website isn’t working out for me. Thanks for the link, though.

    Thanks, Kjodle! Before you posted I had a friend help me out and it was such a “duh” moment for me. He explained that I needed to long in where the wp-admin files were in my FTP, which was located in the “blog” folder. I feel kind of stupid for not figuring that out myself, yet at the same time I felt like I had to dance around the internet and jump through hoops before somebody sat down, looked at it for five seconds and figured it out. I’m a very visual person and would rather have somebody help me through something so that I can see what they’re doing and not have to read about it.

    Thanks, though! You posted about five minutes after this was settled, haha. There will be many more posts by me in the future about what the heck I’m doing 😉

    it was such a “duh” moment for me

    Don’t worry, I’ve had a ton of those. That’s why I’ve written a number of WP tutorials on my blog. Gotta share the good news.

    I’m a very visual person

    Me too. That’s why I include a lot of screen caps. Check my tutorials; if there’s something you need to know, drop me a line and I’ll write a tutorial for it if I can figure it out.

    There will be many more posts by me in the future about what the heck I’m doing 😉

    Looking forward to it!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘The Dreaded 404 Error for New Website’ is closed to new replies.
Skip to toolbar