Support » Multisite » [Resolved] The domain mapping plugin only works if the site is installed in /.

[Resolved] The domain mapping plugin only works if the site is installed in /.

  • Having issues with the multisite…

    Here’s our setup:
    • Main multisite domain is at http://www.domain.com
    • Other multisites are in subdirectories: http://www.domain.com/sub1/, http://www.domain.com/sub2/ etc.
    • I parked several domains on top of http://www.domain.com
    • Using the plugin, I mapped those domains to subdirectories on the multisite
    • If I don’t make the domains as primary, everything works fine
    • If I make the normal URLs (www.sub1.com) as primary, then I can see the frontend site just fine, but getting this error when trying to reach that site’s dashboard:

    “The domain mapping plugin only works if the site is installed in /. This is a limitation of how virtual servers work and is very difficult to work around.”

    I don’t understand how it applies — our main site is installed in / and always has been (as far as I know!)

Viewing 15 replies - 1 through 15 (of 24 total)
  • I have discovered that originally this multisite was set up at an IP address like this:

    It has since been moved to http://www.domain.com but I’m guessing something’s left over from the time when the main domain wasn’t in the root.

    Where would I look for the “leftovers” in the database?

    Thanks in advance!

    Thank you. I did a basic search earlier today and examined each instance of the old URL. Didn’t find anything relevant.

    On another but possibly related note, if I login to a mapped domain dashboard using superadmin user/pass, I still get the error, but when I return to the frontend, it gives me that admin bar at the top. Then if I click on My Sites -> Network Admin -> Dashboard, it takes me to the wrong URL, that’s missing COLON “:” like this


    I just upgraded the network to the latest WP version but that didn’t help anything.

    Protip: If you don’t think it’s relevant, but you’re STILL having issues, it’s possible you’re wrong 😉

    Also make sure you updated the wp-config.php

    Good tip 🙂 doesn’t hurt to be reminded.
    Just used the script. It replaced 3 records and that didn’t fix it either.

    Any ideas as to the missing : in URL?

    Thank you!


    This is from wp-config:

    define('WP_ALLOW_MULTISITE', true);
    define( 'SUNRISE', 'on' );
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'www.domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    Unrelated issue:

    Don’t use WWW. Change this:
    define( 'DOMAIN_CURRENT_SITE', 'www.domain.com' );

    to this:
    define( 'DOMAIN_CURRENT_SITE', 'domain.com' );

    Related issue
    Search your DB for http// just for a laugh.

    Done and done.

    1) I think it might actually be related to the subfolder install problem. Probably a ‘:’ or ‘/’ missing somewhere and causing both issues. I mean, it’s possible, right?

    2) Nothing found for http//

    I think the two are related, because I only get the Dashboard and Logout links with “http//” from the mapped domains’ frontend. When those mapped domains aren’t primary, Dashboard and Logout links work fine.

    (while the backend of the same mapped domains doesn’t work at all due to the above “…only works if the site is installed in /.”).

    Which plugin are you using to map?

    This one: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    I found just one other one – PRO something, but couldn’t figure out if it would help.

    I’m using that one and it’s okay. So I suspect you’ve applied settings wonky.

    Examples from my site:


    I use that plugin on another multisite network that works fine, and copied the settings from there. One difference – the other network is on subdomain setup, not subfolder.

    In the mapping options I have only 2 items checked:
    “Permanent redirect” and “User domain mapping page”.

    To summarize, when I set the http://www.subdomain1.com etc. as primary:
    http://www.subdomain1.com frontend works;
    http://www.subdomain1.com/wp-admin/ throws out “The domain mapping plugin only works if the site is installed in /. This is a limitation of how virtual servers work and is very difficult to work around.”
    • If I check “Redirect administration pages to site’s original domain…” in the Network Admin mapping options, I can (sort of) access http://www.subdomain1.com dashboard, but of course it takes me to http://www.domain.com/sub1/
    This is also when I get the broken logout/dashboard link with the missing colon (:) — that’s why “sort of”.

    If I don’t set http://www.subdomain1.com as primary, it redirects me to http://www.domain.com/sub1/ just fine, and everything else works as it should.

    I really appreciate you trying to understand and help, not easy to get the full picture this way 🙂

    What OTHER plugins are you running? Something’s GOT to be conflicting here…

    • Constant Contact Widget
    • Diamond MultiSite Widgets – hmmm, this one’s suspicious (pushes posts to multiple sites on the network simultaneously)
    • Events Manager – on some sites, not all of them
    • Featured Content Gallery
    • Featured Page Widget
    • Genesis runs on 2 sites out of 7
    • Google Analyticator
    • Gravity Forms
    • Homepage Featured Posts Widget
    • List Category Posts
    • Login Form Shortcode
    • Redirection (no rules in place right now)
    • Relevanssi Premium Search
    • Restricted Site Access (running on a few, not all)
    • Widget Logic (on some)
    • WordPress Access Control (password protects individual pages, including the sidebar)

    Should I start disabling them one by one? Anything jumps out at you?

    I ran Diamond MultiSite Widgets and it was fine.

    Turn off Redirection (I know you have no rules in place, but …)

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] The domain mapping plugin only works if the site is installed in /.’ is closed to new replies.