Support » Fixing WordPress » The connection was reset

  • Resolved yogirajj


    I have been running two blogs for a little over 7 years using wordpress. However, this past week, all of a sudden I get the following error. “The connection was reset”

Viewing 15 replies - 1 through 15 (of 16 total)
  • I can’t seem to post anything, or preview any pages, without getting The connection was reset” error

    Moderator t-p


    Most probably this has to to do with your server setting.

    If you are not the host yourself, have you contacted your hosting provider?

    Yes, they say they can’t find a problem, and for me to contact wordpress. This is getting frustrating. I tried uploading a photo and wordpress gave me an error and says try again later. I also tried to re-install wordpress, and it did not help the problem.

    Moderator t-p


    Have you tried:

    -deactivating ALL plugins temporarily to see if this resolves the problem. If this works, re-activate them individually (one-by-one) to find the problematic plugin(s). If you can’t get into your admin dashboard, try deactivating via FTP or SFTP or whatever file management application your host provides. If applicible, also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old.
    – To rule out any theme-specific issue, try switching to the unedited Twenty Twelve default theme for a moment using the WP dashboard. If you don’t have access to your admin area, you can switch to the default theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using via FTP or SFTP or whatever file management application your host provides.
    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).
    – If the above troubleshooting steps do not resolve the issue, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!

    Most of the times this error has nothing to do with WordPress. You’ll need to contact your hosting provider and have them look at the server / error logs. Perhaps your website is hitting a memory limit?

    Who is your hosting provider? You may want to look at the WordPress Recommended Hosting Providers.

    the only two things I’ve installed was the Captcha, and the Captcha form. I deactivated both, and still had a problem. I then deleted them and I still had a problem.I didn’t think about manually re-uploading folders. Isn’t re-install button is the same thing?

    Thank you Patrick. I am on the phone with godaddy right now. I am putting my foot down. I operated two blogs collectively for about 7= years and never had a problem till now. They admitted they did some kind of maintenance & update a couple of days ago; and because they don’t have an answer for me, they want to quickly blame wordpress.

    Hi yogirajj. I have had the exact same issues that popped up on Saturday and have been persisting ever since.

    Did you have any luck with godaddy on the phone? If so, what did they tell you?

    I have been emailing back and forth with several of their support people who say they can not replicate the issue, but lo and behold I have the issue every single time I am logged in.

    More than likely, this is related to you php.ini file.

    That file has a couple of settings that need to be changed, after which 99% of issues will be solved. I’m currently in the 1% of people for whom the following solution does NOT work, but for most people…

    Optimizing the php.ini file for WordPress
    You need to increase your php.ini limits. This is something you can do if you have root access, but more than likely is something you will have to ask your host to do. Godaddy is AWFUL with this issue – they don’t WANT to fix it, but they are well aware of it.

    Settings to change:

    MEMORY_LIMIT = 32M (Whatever it is set at now, it should be 64M or greater…128M is ideal and also the max). This is the limit for memory consumption for scripts, and often things like uploading themes require more than the default value.

    UPLOAD_MAX_FILE_SIZE = 2M (Default is 2MB, obviously this is low. 8-10MB should be doable depending on how cooperative you host is being today, if you’re VPS or dedicated, you can set this at whatever.

    If you host doesn’t know/care about finding your php.ini file, create a new txt document and paste in:


    Save it as info.php and upload to the root of your website folder (usually via FTP or a file manager) – then just visit and it will tell you exactly where your php.ini file is. Pass this info along to your host, although they really should be competent enough to know how to edit the php.ini file…

    Hope this helps!

    Hi Trevor,

    All my “page reset” issues have been resolved. The problem is DEFINITELY on Godaddy’s end. They have done a recent security upgrade. The only reason why I know this was because I called just before (the page load incident), concerning connectivity issues via my FTP. The rep did not want to go in to detail, however, I do know that it had something to do with their Apache Server. The level 2 tech support asked my for my IP address so that it can be “white listed”. I was not comfortable doing that via email, so called them directly and I gave them both my home IP and my VPN address. So far I haven’t had any issues any more.

    Bottom line, Whatever it was that caused the problem, I did not have any write privileges, while using WordPress, despite the fact that the FTP issue was resolved. This was hard to get through the first rep’s head; ’cause the crazy women kept insisting it was one of my plugins. I told her I am not an idiot, I have been working with computers while she was still in diapers!

    My suggestion to you Trevor, is to ask the Godaddy rep to turn on logging, so that the level 2 techs can decode whatever information is being produced inside your log files. That’s how the eventually caught my problem. Good luck!

    [Signature removed by moderator per forum rules.]

    Hi dinidh,

    Thanks for the info. Although my issue has been resolved, this is still great information. I’ll keep it handy!

    I had the same problem and figured out that it was caused by Googles mod_pagespeed apache module. I installed this before for another blog running on the same server as it increases the page speed a lot, but by installing a new wordpress installation it threw several errors.

    By deleting the pagespeed.conf and pagespeed.load files from /etc/apache2/mods-enabled/ I solved my problem.

    I will have to figure out how to use pagespeed properly

    For sure this is not suitable for everybody but might help some of you

    Thank you. It turned out to be a number of plugins I was using that caused my reset errors. The biggest culprits were the Captcha plugins and the Anti-Spam. In the end, it just wasn’t worth the headaches. I decided to uninstall all of them, and disable the sign-up feature. If anyone wants to be a member of my blog, I’d rather sign them up manually. Thanks again..


    Moderator t-p


    Glad you got it resolved 🙂



    Hello all,

    I have got the same error like connection was reset.
    I am got this error in my localhost.
    Any help for it.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘The connection was reset’ is closed to new replies.