Support » Plugin: Advanced Ads – Ad Manager & AdSense » The code for this plugin is showing up in my intro text

  • Resolved JIGSAW

    (@jigsaw)


    As you can see in the page I linked to and this link to a screen shot of my site.
    This plugin’s code is showing up in my intro text. Anybody have any idea how I would go about not showing this code to my users in my intro text for each blog post?

    2018-11-29_0615

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi JIGSAW,

    thanks for reaching out.

    Did you create an AdSense ad unit on your site?
    Is it possible that you choose a content injection, e.g. Before Content in Advanced Ads > Placements?

    Advanced Ads should not inject ads into excerpts by default. If you have indeed an auto-injection placement enabled, you can go to Advanced Ads > Settings > General and disable Unlimited Injection by entering a 0 there.

    Let me know if that helped.

    Thomas

    Thomas,

    Thank you for your quick response. I did set the unlimited injection to 0, but now all the ads have been removed from my posts. Besides the ones I manually added before installing this plugin.

    Its a wonderful plugin, but I have a custom wordpress site and it doesn’t appear to be compatible.

    Wish i could use this plugin.

    Plugin Author Thomas M

    (@webzunft)

    Hi JIGSAW,

    thanks for your feedback.

    One more thing I could think of: set Unlimited Injection to whatever you need, but disable ads in “Secondary Queries” at the top of the settings page.

    Depending on how your sites are coded, this might help.

    If not then I am really sorry that there doesn’t seem to be a simple way for you using Advanced Ads.

    Thomas

    Thank you again for your swift responses. Even though I can’t use this plugin I gave you guys a 5 star review. But after days of research and googling. Again I am not a coder or developer who I am sure this would be a 10 second fix. Is there a using CSS to block this (adsbygoogle = window.adsbygoogle || []).push({}); from displaying on the front end?

    OR

    is there a way the CSS or Code of this particular plugin can be changed so that it is not detected until after the 3rd sentence of blog posts on “my” site? Because my site only draws from the first 2 sentences for intro text.

    Plugin Author Thomas M

    (@webzunft)

    Hi JIGSAW,

    this is, unfortunately, no problem that could be resolved with CSS. The ad code is injected into the content, but some function removes HTML tags from it, so all that is left is the part you are seeing.

    Did you try the “Secondary Queries” suggestion?

    You can also remove this particular ad from archive pages using the “General Condition” in the Display Conditions with the “Archive” option disabled.

    The placement which contains the ad is Before Content 6. You can apply the suggestion above to that particular ad.

    Please let me know if that helped.

    Thanks,
    Thomas

    Every plugin designer should take customer service lessons from you and your crew. So swift and relevant. I wasn’t expecting a reply until sometime tomorrow. I did try the secondary queries suggestion that was made. Didn’t do anything.

    When you say “content 6” are you referring to the 6th ad I created? So if I delete that particular ad this should all go away ???

    Plugin Author Thomas M

    (@webzunft)

    If you reach out at the right time then I see your message 🙂

    “Before Content 6” is a placement. You will find it in Advanced Ads > Placements.

    This is the default naming we have for placements which are created automatically when choosing a placement right after saving the ad for the first time.

    I cannot say which of your ads this is, but see the placement name in the source code. You can go to Advanced Ads > Placements and look for it. Then click on the link next to the item option to jump to the ad directly.

    You can also remove that placement or just the item option to remove the ad, but it will remove it also from the single pages. I’d go with the Display Conditions > General Options. Well, just try disabling all options except Singular Pages as on the screenshot below.

    display-condition-singular-pages

    Thomas

    IT WORKED!!!

    IF YOU EVER NEED A TESTIMONIAL, REVIEW WHATEVER YOU NEED FOR MORE AWARENESS FOR YOUR PLUGIN OR CUSTOMER SERVICE ACKNOWLEDGEMENT COME KNOCK ON MY DOOR.

    • This reply was modified 1 year, 10 months ago by Andrew Nevins. Reason: Spam removed

    Please see screen shot

    2018-12-04_0800

    Plugin Author Thomas M

    (@webzunft)

    Thank you.

    I see that you are using the AdSense Auto ads code on single pages. This would allow AdSense to place ads automatically wherever they want. I saw at least one Auto ad on your site when I just checked.

    Please check in your AdSense account under My ads > Auto ads if you enabled them. You can also remove the Auto ads code. It is the one with enable_page_level_ads in it or was enabled through Advanced Ads > Settings > AdSense.

    Thanks,
    Thomas

    Thomas,

    Thanks again for being so prompt. Can you please explain enablepage level ads. I can’t seem to find it on this article and I don’t know what that means.

    https://wpadvancedads.com/adsense-in-random-positions-auto-ads/#utm_source=advanced-ads&utm_medium=link&utm_campaign=backend-autoads-ads

    Plugin Author Thomas M

    (@webzunft)

    Page level ads was the old name for “AdSense Auto ads”.

    I explain how to enable them in https://wpadvancedads.com/adsense-auto-ads-wordpress/.

    You can try to revert that setup. Whether you enabled it through Advanced Ads or not, disabling Auto ads within your AdSense account would help. It will need 30 minutes until changes are visible on your site (i.e., Auto ads stop appearing).

    I might also be wrong about the Auto ads in the header. It could still be something else. But I didn’t see the AdSense header ad appearing on your site.

    My reply rate will slow down the next days since I am leaving for a conference.

    Thomas

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘The code for this plugin is showing up in my intro text’ is closed to new replies.