Support » Plugin: Scriptless Social Sharing » The blog posts doesn’t load

  • Hi!
    I tried to use this plugin on a website I was creating for a customer, it works with Astra + Plain Gutenberg. And with this plugin active the blog posts doesnt load, it keeps loading and loading, and doesn’t open.

    What can be causing this?

    • This topic was modified 4 months, 1 week ago by taisa1984.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Robin Cornett

    (@littlerchicken)

    Do you mean that an individual blog post does not load at all, and there is just a white screen? Or does part of the page load, and not the rest? Or something else?

    If there is a PHP or server error, that should be logged on your site–your host should be able to help you find the error logs if you are not sure where to look.

    If the page is partially loading and then getting stuck, that could be some kind of JavaScript error, and you may be able to see where it’s coming from with your browser’s dev tools.

    If you can share a link to an affected page, I can try to look, but I can understand you may not want to have the plugin running if you believe it’s causing issues. One approach to try might be to enable the plugin, but uncheck all of the settings to automatically display the sharing buttons, and then add them to just one page and share that link so we can look at it and see if we can figure out the issue, so then you could share just the link for the one affected page.

    Thread Starter taisa1984

    (@taisa1984)

    Here is a copy of the website. I can’t have this happening on the public website.

    Blog posts:
    https://hablaconmigo.taisawebsyblogs.com/mis-trucos-durante-el-confinamiento/
    https://hablaconmigo.taisawebsyblogs.com/mantener-tu-lengua-materna/

    I just tried to change to a default theme, and disabling all the other plugins, and it still happens.If I disable the plugin, the blog post works, so it must be the plugin.

    What happens is that it just keeps loading and loading. After a while sometimes returns a a 503 or 403 error.

    This also happened on the other server where the web is, so it is not a server issue, and only happens with blog posts (there are more links on the footer widget). The rest of the website works fine.

    The only error that appeared on the search console was the server error.

    All is updated. I also tryed deleting the plugin and installing it again, changing settings… but nothing makes it work.

    Thanks for taking a look into this. I like this plugin, because it is simple and has Whatsapp sharing. It is working just fine on other websites I manage. But I don’t get what is happening here.

    • This reply was modified 4 months, 1 week ago by taisa1984.
    Plugin Author Robin Cornett

    (@littlerchicken)

    Can you share a screenshot of your settings for Scriptless?

    You said that you’ve disabled all other plugins, correct? And it’s still happening? I think we need to look at your PHP error log (you may need to enable WP_DEBUG and trigger the error to get extra logging data), as I’m unable to replicate the issue and the issue is not able to be diagnosed from the front of the site.

    Thank you for your patience, and I appreciate you setting up the copy of your site. Hopefully we can get this sorted together.

    Thread Starter taisa1984

    (@taisa1984)

    Hi!

    Here are the setting, I changed some of them to test, and they are the same as other of my sites where the plugin works fine.
    https://hablaconmigo.taisawebsyblogs.com/wp-content/uploads/2021/05/screencapture-hablaconmigo-taisawebsyblogs-wp-admin-options-general-php-2021-05-19-10_43_48.png

    Here is a video of what happens, only on blog posts, and I also show the settings too, how other plugins are inactive, and the theme is the default twentytwentyone for testing purposes:
    https://vimeo.com/552305977/316068c3d8
    This happened too on other server (PHP 7.4 on both), from other devices and to other people too.

    Here on this video I show how I disable the plugin, and the blog posts works fine:
    https://vimeo.com/552307084/3c3a08fe0e

    Thanks and regards,

    Taisa

    Plugin Author Robin Cornett

    (@littlerchicken)

    Thank you for the screenshot and additional details. Unfortunately, I’m still unable to replicate. If you do not have access to your PHP error logs, can you try adding a plugin called Query Monitor to the copy of your site, and see if it is able to tell you the errors that page is returning? It may not be able to if the page is not completely loading, but it’s worth trying. If some PHP is causing an error, having the specific error log information will be helpful.

    Thread Starter taisa1984

    (@taisa1984)

    What do you mean yo can’t replicate? The post entry loads completely when you try to enter them?

    With the Query monitor it loaded but only title and featued image, nothing more. But query monitor.. it returns an error.

    I also activated debug option, and there is no PHP error.

    I think I will just try other sharing plugin.

    Thanks for trying.

    Plugin Author Robin Cornett

    (@littlerchicken)

    I can see the behavior on your site, but just the behavior is not enough to help me diagnose what’s going on–there are no user facing errors being displayed. I have set up a site with the same theme, language, and plugin settings, and it’s working fine, so I have not been able to make the same thing break, whatever it is.

    I suspect there is a PHP error, which is why I asked about the PHP logs, or seeing if Query Monitor would show a PHP error if you do not have access to the logs. Unfortunately, without some kind of log, I don’t have any way to determine what’s going on. I’m sorry to not have been able to help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.