Support » Plugin: Networks for WordPress » What The Basic and Essential Settings for Multisite Sites To Make Them Work?

  • Resolved frank tredici

    (@frank13)



    I have a multisite installation with 3 sites. I am growing it with more sites.

    I have installed and network-activated the Networks for WordPress 1.1.5 plugin.

    I have tuned wp-config.php and .htaccess per instructions.

    I needed to install a new theme for one of my sites so I went to My Sites > Network Admin > Sites

    I clicked Networks

    I clicked Assign Sites on my main site and assigned one of the sites to it (the one I needed to activate the theme on)

    I activated the theme and then Unassigned the Site.

    Now the site does not resolve — it loops with a URL of http://janetgane.com/wp-signup.php?new=janetgane.com

    Also, the site now shows as *Site Title* (holdings.blogs.local/)

    How do you solve this and can you give me tips on how to properly configure WPMS?

    Thanks.

    http://wordpress.org/plugins/networks-for-wordpress/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Here is a snapshot of my 3 network sites from the My Sites > Sites > Networks

    ID	Network Name	Domain		Path	Sites	Super Admins
    1	Main Site	domain.com	/	1	supadmin
    2	Site Two	janetgane.com	/	0	supadmin
    3	Site Three	domain.net	/	1	supadmin

    So what does it tell you if the Sites value is 0 for my Site Two when the Sites Value is 1 for the other two sites?

    And what can I do to fix that?

    Plugin Author David Dean

    (@ddean)

    When you unassigned the site, you sent it to the holding network – that’s what site_id value 0 and “holding.blogs.local” indicate.

    You should assign it to a network to restore access. Click Assign Sites on the network where you want the site to be accessible, and assign that site to it.

    Please let me know if you have any other questions.

    – David

    Holy cr*p @DavidDean. That was awesome and so powerfully useful. (good bye anxiety!)

    This tip needs to be part of documentation somewhere.

    Never, was that made clear in any of the places I looked!

    I am getting to feel a little better about this plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘What The Basic and Essential Settings for Multisite Sites To Make Them Work?’ is closed to new replies.