Support » Fixing WordPress » The backup of this post in your browser is different from the version below.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    It’s not an error, it just a notice informing you that your browser’s local storage has a different version of the post. Maybe you started to edit the post at one time, but rather than saving or updating it, you left it.

    You can either restore from the browser’s copy, or click the x at the top-right of the notice to close the notice.

    Oh okay 🙂 , and thanks James for the info

    @james Huff

    How to turn off this warning notification permanently?

    Presently facing this notification several times. pls help

    I get this warning every time I save. Seems like a bug.

    • This reply was modified 8 months, 2 weeks ago by  aaron843.

    I also keep getting this error, very frustrating. Have tried multiple things to troubleshoot.

    • This reply was modified 7 months, 3 weeks ago by  zendeb.

    To help people if they still get this and can’t figure out why, it is often caused by rogue bits of code in your text.

    Look at the “Text” tab of the edit area, and find any &nbsp or unrequired <div> or </div> tags.

    They very often occur if you C&P from other web pages. Basically, your browser is trying to apply the divs but the WordPress editor doesn’t recognise them, and this causes a conflict which shows as the error message you see.

    Deleting the unused tags should should fix the problem in most cases.

    Hi migster, thanks a lot for your post!!
    For me this issue was indeed resolved when I corrected some CSS-‘coding’ (in a completely unrelated page). I had forgotten a closing ‘}’.

    I’m glad it pointed you in the right direction!

    This is most definitely a bug. Update a page and immediately it gives this message. How can the backup in my browser be different when I’ve just updated it? I’ve just updated so of course the browser backup can’t be newer!

    It seems to me there’s a bug that however this is stored in the local browser is not updated when the post is updated, causing it to fail a check on the reload, even though the database copy is newer than whatever the browser is holding, because I just updated it.

    It’s causing a bit of a problem because users don’t know why it randomly says this for no apparent reason. The only way to get rid of it is to restore the browser backup, because no matter how many times you update it, this message just comes back.

    And no, not down to div tags or non-breaking spaces.

    • This reply was modified 5 months, 1 week ago by  regisit.

    I’m having the same issue (in woocommerce). I “restored the backup”, and cleared all formatting. When I click update, the same message appears. Clicked “restore the backup” again, then clicked update straight away… Same story. Cleared the cache and repeated different sequences of clear formatting, recovery and update. You can click the x and it goes away, but reappears whenever you click update.

    Weirdly, I had the same problem in WooCommerce yesterday. I found it was every time a product was created which had a + in the product name.

    I don’t know if that matches what you see? It’s annoying, even if not fatal.

    @migster , I didn’t have a “+”, but I did have braces. I took it out and updated. There was no message. When I put it back and saved it once more, the message still stayed away. I think it would be safe to call it a bug. Like you said… It’s anoying…

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘The backup of this post in your browser is different from the version below.’ is closed to new replies.