Support » Plugin: AWS for WordPress » The aws sdk usage seem to conflict with other plugins using aws sdk

  • Some help would be appreciated on the this.
    After trying to install various wp backup plugins suitable for use with S3 and failing as WP would return an 500 error afterwards; one of them finally gave more output (and failed to activate as well).

    Fatal error: Cannot redeclare Aws\manifest() (previously declared in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/amazon-polly/vendor/aws/aws-sdk-php/src/functions.php:322) in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/backup-wd/vendor/aannnaa7/aws-sdk-php-minimized/src/functions.php on line 320


    In this case I tried to activate the plugin ‘BackUp WD’ by WebDorado; but at least 3 others alike failed. I can’t say where the issue is, or if its a containment issue of Polly plugin, but any feedback would be welcome.

    wp: 4.9.8
    php: 7.0.30
    WpPolly : 2.5.5

Viewing 3 replies - 1 through 3 (of 3 total)
  • I just tried to download a database file uploaded to an S3 bucket in UpDraftPlus and received this:

    Download db (Sep 14, 2018 11:44):
    Error: Download failed

    S3 Error: Failed to initialise: Missing required client configuration options: version: (string) A “version” configuration value is required. Specifying a version constraint ensures that your code will not be affected by a breaking change made to the service. For example, when using Amazon S3, you can lock your API version to “2006-03-01”. Your build of the SDK has the following version(s) of “s3”: * “2006-03-01” You may provide “latest” to the “version” configuration value to utilize the most recent available API version that your client’s API provider can find. Note: Using ‘latest’ in a production application is not recommended. A list of available API versions can be found on each client’s API documentation page: http://docs.aws.amazon.com/aws-sdk-php/v3/api/index.html. If you are unable to load a specific API version, then you may need to update your copy of the SDK. (line: 371, file: /var/www/html/wp-content/plugins/amazon-polly/vendor/aws/aws-sdk-php/src/ClientResolver.php)

    Plugins with different versions of the SDK seem to present issues.

    Plugin Contributor tstachlewski

    (@tstachlewski)

    Hi guys,
    I’m aware of this issue. It’s annoying also for me, the problem is that there is no fix for this issue at this stage. The problem is that the Amazon Polly plugin is using AWS SDK for PHP v.3, while some other plugins still use old v.2. The problem is that those two versions are not compatible…

    I was looking at the source code and don’t want to make an assumption that is not true. Does the Polly plugin load the AWS SDK every time WordPress handles a request and the initialization functions are ran? If so, would it not be more efficient to only load the SDK when it is needed? I wonder if this would help with the version conflicts with other plugins.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘The aws sdk usage seem to conflict with other plugins using aws sdk’ is closed to new replies.