Support » Fixing WordPress » The Authorisation header is missing

  • I keep getting this error when I check our site health tools:

    The Authorisation header is missing

    The Authorisation header comes from the third-party applications you approve. Without it, those apps cannot connect to your site.

    Flush permalinks

    I have tried to flush the permalinks multiple times and I’ve also tried to add the below snippet of code on the C-panel:

    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    so the code looks like this:

    # BEGIN WordPress
    # The directives (lines) between "BEGIN WordPress" and "END WordPress" are
    # dynamically generated, and should only be modified via WordPress filters.
    # Any changes to the directives between these markers will be overwritten.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    but it did not work either.

    do you have any other suggestions that I could try in order to fix this issue? Currently, some third party plugins cannot be connected to the site due to this issue.

    Any feedback would be greatly appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Scott

    (@midipedalboards)

    I have the same issue.

    Scott

    (@midipedalboards)

    I actually fixed my issues. Everything, including .htacess looked right but I still got those errors. I am running PHP 7.1.4, WordPress 5.7.1 between 3 websites on a dedicated virtual server.

    2 of the 3 websites gave the “The authorization header is missing” error but 1 didn’t.

    So I got to examining everything. I even did a strip down reinstall of a basic WordPress install with no modules activated. Same thing.

    Then I noticed even though all three had the same version of WordPress, had separate identical .htaccess files, and the same version of PPP … only the one website that wasn’t giving the error was was running PHP 7.1.4 FastCGI and the two giving the error were running plain ‘ole PHP 7.1.4.

    So I changed the two sites to the FastCGI version of PHP 7.1.4 and … no more error. No more issue.

    Hope that helps someone else.

    Scott

    (@midipedalboards)

    PHP not PPP as I mistyped above

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘The Authorisation header is missing’ is closed to new replies.