Support » Plugin: Schema » The attribute logo.itemtype has an invalid value.)

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Hesham Zebida

    (@hishaman)

    Would you please provide a link to the page that has the issue? I need to inspect the markup and see the error.

    Thanks.

    Evelyn

    (@whatsinmybag)

    Thank you for the response, I have checked on the google structured data testing tool : https://search.google.com/structured-data/testing-tool/
    And the problem I got there-
    Link : http://prntscr.com/lyczvj

    Plugin Author Hesham Zebida

    (@hishaman)

    I see the issue is within the Publisher logo image, for some reason the plugin can not retrieve image attributes.

    Maybe try to upload another logo image following Google’s Publisher Logo guidelines.

    Publisher Logo should have a wide aspect ratio, not a square icon, it should be no wider than 600px, and no taller than 60px.

    Evelyn

    (@whatsinmybag)

    Yes, Thanks for the response again. I have tried several times uploading with the resolution mentioned there for publisher logo, Which is 112*112 PX, Can it be possible, it is showing the error because I am using a yoast plugin and has the same feature for logo ?

    Plugin Author Hesham Zebida

    (@hishaman)

    Image should not be a square, it should be no wider than 600px, and no taller than 60px.

    At any how, the plugin tend to use the correct attributes, but I don’t know why it’s not retrieving these on your website.

    I can’t assist you with this issue without debugging your site, which is out of the scoop of plugin support. Sorry!

    Maybe you can try to find any relevant errors in the error log file?

    Let me know.

    Evelyn

    (@whatsinmybag)

    I am getting error on knowledge graph logo , Please check the screenshot if it helps.
    http://prntscr.com/lyw4c4
    Logo guidelines : https://developers.google.com/search/docs/data-types/logo

    Two additional notes:

    1. My “publisher” logo is 60 x 243 per guidelines.

    2. The warnings only appear on the homepage.

    PS Revised the publisher logo to be exactly 60×600.
    Again, the 3 logo warnings only appear on the homepage.

    Operator error, i.e. my fault. Fixed it.

    Grazie.

    Having same issue here on Blog Publisher logo on my home page – it would say for BlogPosting Publisher ‘logo.itemtype has an invalid value’ Warning on the Google Structured Data Testing Tool. In the Schema plugin I have a 60 (height) by 600 (width) logo set in the “General” tab of the Schema plugin configuration page.

    The next tab is the Knowledge Graph tab, which also asks for a logo which I understand must be square and at least 112 by 112. No matter what I put in there size-wise (even a square box), the Google Tool would throw the error noted above. So, I left the image item there blank, hit Save, cleared my cache and re-tested. Now I have 0 errors, and somehow Google is seeing the Publisher logo from my “General” tab and populating that in the Blog Publisher field as well, which I think solved the issue for me.

    Not sure if this is a glitch unique to my site or something that might help debug the issue. For each Blog entry it looks like it has 4 or 5 entries for this logo, so not sure if it is something with my theme. In any event, the Warning message is gone for the time being. I don’t know how I will be able to insert a graphic (112 by 112 or something like that) into the Knowledge Graph tab without this problem reappearing, but that is for another day.

    Evelyn

    (@whatsinmybag)

    I am still getting the problem for the knowledge graph logo, any help would be appreciated https://whatsinmybag.in

    @bdconnoly If you don’t mind me asking, what did you do to fix it?

    Still Same issue

    @albie2011 I have had exactly the same problem, but thanks to you I’ve at least found a workaround.

    Deleted the Knowledge Graph logo, that I had also done as per Google instructions 112 x 112 and tried other combinations. Different sizes and formats.

    Thanks for saving my sanity!

    Hopefully the developers will come up with a solution soon.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.