Support » Plugin: WooCommerce » The API credentials you provided are not valid

  • Resolved captnanubis

    (@captnanubis)


    Helllo,

    Recently been hired to fix a problem on a clients website they have been using the same api username password and signature for a year and all of a sudden it has now thrown up error 10002 at checkout.

    went into ecommerce payment PayPal manage, and compared the existing api details with the ones he screenshot for me and re-entered the password to make sure.

    No success so pressed the rest and re-entered the details again still getting the same error. (Error: The API credentials you provided are not valid. Please double-check that you entered them correctly and try again.)

    Regards

    • This topic was modified 3 months, 2 weeks ago by captnanubis.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @captnanubis,

    When PayPal returns a 10002 error PayPal is indicating that the API details being sent to PayPal are incorrect. This documentation below describes the reasons for this PayPal error code in more detail.

    https://www.paypal.com/us/smarthelp/article/why-did-i-get-api-error-code-10002-ts1030

    If you enable WooCommerce > Settings > Payments > PayPal Standard > Debug log and attempt to carry out a test payment it should log the PayPal response to a log file.

    You can then access that log file by navigating to WooCommerce > Status > Logs which should hopefully provide you with some further information with regards to the message.

    Hello Stuart,

    When i press save on paypal checkout settings under manage the error pops up.

    The API credentials you provided are not valid.

    They are the exact same api details on paypal.

    They were working for about a year and now woocommerce won’t except them.

    Regards

    Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @captnanubis,

    I’ve performed some cross-testing for us on one of my sites which have the latest versions of WordPress, WooCommerce and our free Storefront theme as the only enabled software. When doing so I’ve not been able to replicate the behaviour which you describe with regards to the PayPal API credentials not being accepted or saving.

    What version of WooCommerce is installed on the site you’re entering those details on?

    Hello stuart,

    woocommerce v4.5.2

    WooCommerce PayPal Checkout Gateway v2.03

    Regards

    P.S Thank you for your time in trying to help me it is greatly appreciated

    Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @captnanubis,

    For reference on my test install, I have WordPress v5.5.1, WooCommerce v4.5.2 and PayPal Checkout v2.0.3 installed.

    When I click this button below and login to my test account the API details are automatically populated.

    Image Link: https://cloudup.com/cRIhIM676TI

    I also tried the link click here to toggle manual API credential input. to manually enter the details and that worked for me too.

    Have you tried disconnecting from PayPal and then using the Setup or link an existing PayPal account button to connect again. That process should auto-populate the API details unless something is amiss on the PayPal account itself.

    As the site is using the free WooCommerce Paypal Checkout plugin it may be worth posting your question in the PayPal Checkout forum which is this one below.

    https://wordpress.org/support/plugin/woocommerce-gateway-paypal-express-checkout/

    Hello Stuart,

    I have tried the reset and reinsert the api details and still not accepting.

    Error: The API credentials you provided are not valid. Please double-check that you entered them correctly and try again.

    regards

    Plugin Support drwpcom

    (@drwpcom)

    Hi @captnanubis. Sorry that we missed you response. Are you still facing this issue? If so, I hope my response helps.

    I had this issue on one of my test sites with PayPal Standard. To resolve it, I deleted the API signature that I had created in my PayPal settings and then made a new one by following this guide. I then copied those new credentials to WooCommerce > Settings > Payments > PayPal.

    Please try that and let me know if you have any follow-up questions.

    • This reply was modified 1 month, 3 weeks ago by drwpcom.
    Plugin Support drwpcom

    (@drwpcom)

    Hi @captnanubis. We haven’t heard from you in a while so I’m going to go ahead and mark this thread as resolved. If you still need help with this issue or have any other questions about the WooCommerce plugin, please start a new thread.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.