Support » Plugin: AMP for WP - Accelerated Mobile Pages » The ‘amp-pixel-latest.js’ custom script appears after updating to 1.0.8

  • Resolved tiagoelav

    (@tiagoelav)


    Hi! I have found a new issue after update to 1.0.8. A script related to the amp-pixel appears automaticaly into the header when I insert the pixel AMP tag into the footer. The AMP project hasn’t a script to amp-pixel tag, it doesn’t exists, this link return a 404 and the Google Search Console has the error “Custom JavaScript is not allowed”.

    So, I decided to rolled back to my last version (0.9.98.22) and open this support topic. Probably, the plugin has other tags with the same issue, not only amp-pixel. Something related to the autoloader or sanitizer process.

    the script:
    <script custom-element="amp-pixel" src="https://cdn.ampproject.org/v0/amp-pixel-latest.js" async></script>

    the pixel tag:
    <amp-pixel data-block-on-consent src="//whos.amung.us/swidget/some-id.gif"></amp-pixel>

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    We noticed your error. This bug is valid. We have created a ticket for this bug. We will be fixing this in our future updates.
    reference: https://github.com/ahmedkaludi/accelerated-mobile-pages/issues/4057

    We have fixed this issue in our latest update 1.0.10. Can you please check whether the issue is solved or not.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Please update our latest plugin version 1.0.10. Can you please check whether the issue is solved or not.

    Thread Starter tiagoelav

    (@tiagoelav)

    Hi guys, thank you for the support but unfortunately the bug is not fixed. I updated to the last version (1.0.10) and the amp-pixel tag appeared again. So I removed the pixel tracking code from the footer (Advance Settings > Enter HTML in Footer) and the script disappeared from the header.

    This is what I did to check it and maybe it could help you to debug, adding a simple pixel tracking code (like what I mentioned in the first comment) to see if the amp-pixel-latest.js appears again.

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Hi,
    Can you please update to the 1.0.12 and see if the issue gets fixed for you?

    It should work for sure.

    Rais

    (@raistlinix)

    Hi!

    The error continue in version 1.0.12 … Help please!

    Thread Starter tiagoelav

    (@tiagoelav)

    Hi @ahmedkaludi, thank you for the update.

    I tried the last version (1.0.13) and it look fixed. Thanks!

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    Rais: As per the forum guidelines you have to be created a new topic.

    Rais

    (@raistlinix)

    Hi!
    Sorry, I didn’t want to duplicate the subject.
    With the update the problem has already been solved.

    Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘The ‘amp-pixel-latest.js’ custom script appears after updating to 1.0.8’ is closed to new replies.