Support » Plugin: Custom Dashboard & Login Page - AGCA » The AGCA plugin has detected an error on your site!

  • Resolved bisiesto

    (@bisiesto)


    I have problems activating the plugin, the alert says:

    The AGCA plugin has detected an error on your site!

    And the debugger throws me:

    Deprecated: has_cap has been called with an argument that is deprecated since version 2.0.0. The use of user levels is deprecated. Use the capabilities instead. in /home/asesora/public_html/wp-includes/functions.php on line 5143

    Everything was fine until I wanted to remove a link from the menu as usual and everything broke. I hope you can help me. Cheers!

    ::::::::::::::::::::::::::::::::::::::::::::::::::::

    Tengo problemas al activar el plugin, la alerta dice:

    ¡El plugin AGCA ha detectado un error en tu sitio!

    Y el depurador me arroja:

    Deprecated: has_cap ha sido llamado con un argumento que está obsoleto desde la versión 2.0.0. El uso de niveles de usuario está obsoleto. Utiliza las capacidades en su lugar. in /home/asesora/public_html/wp-includes/functions.php on line 5143

    Estaba todo bien hasta que quise eliminar un link del menú como siempre y se rompió todo. Espero puedan ayudarme. Saludos!

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author cusmin

    (@cusmin)

    Hi Bisiesto,

    This is probably caused by some of your plugins. AGCA just detects the error and displays it. For example, this can happen when using add_options_page function with a capability defined in number instead of a string. Please check this link for more information: https://wordpress.org/support/topic/has_cap-deprecated-since-version-2-0-0/

    To debug this more, please try disabling other plugins one by one, until the issue is hopefully resolved (or search for add_options_page function in plugins directory to see if any plugins is passing number instead of string to this function).

    If you know exactly what menu item you disable in AGCA, and how to trigger this error, please let us know. Thanks!

Viewing 1 replies (of 1 total)
  • The topic ‘The AGCA plugin has detected an error on your site!’ is closed to new replies.