Support » Plugin: Adminimize » The Adminimize plugin needs improvements to work with PHP7.2

  • Resolved Rodrigo

    (@vejapixel)


    Hello guys,

    I’m using the PHP Compatibility Checker plugin to check if the plugins and theme of my site are compactable with the PHP7.2 version, and showed me that the Adminimize plugin is compactable but needs improvements to work with PHP7.2

    https://screenshot.net/pt/yl4s4zd?

    FILE: /var/www/proddigital.com.br/wp-content/plugins/adminimize/inc-setup/remove-admin-bar.php
    -----------------------------------------------------------------------------------------------------------
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    -----------------------------------------------------------------------------------------------------------
     240 | WARNING | Function create_function() is deprecated since PHP 7.2; Use an anonymous function instead
    -----------------------------------------------------------------------------------------------------------

    Thank you,
    Rodrigo

    • This topic was modified 7 months ago by  Rodrigo.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Frank

    (@bueltge)

    Thanks for the hint. There is fixed in the current development version, not released.It would be helpful if you test the dev version and give us feedback – download her https://github.com/bueltge/adminimize/archive/master.zip

    Thanks!

    @bueltge – Perhaps you would get more support if you pinned a notice that you want people to test the dev version and give us feedback, with the link to the zip?

    Plugin Author Frank

    (@bueltge)

    Hi @sonja
    Thanks for your feedback, and idea.

    I tested this in earlier version, no feedback from users 🙁
    Same – no feedback – to the current pinned posts. Also oft I read question threads with the same topic to others. User create really fast a new one, no idea to search or help others. The support is a one men show, so sad.

    Hi Frank, I am interested in helping out. I was going to reinvent the wheel but had other thoughts.

    I’ve got a few plugins up on the repo that I built with WPPB, if you like the way they are built, and want a hand, let me know.

    See https://chrisjallen.com for more info.

    Hi Frank, I’m sorry for the delay, I could not do this test before.
    I installed the plugin version dev 1.11.5, and checked again with the PHP Compatibility Checker plugin and this div plugin is OK: https://screenshot.net/pt/j22lqh1

    Obs.: In the screenshot, Adminimize from above is version 1.11.4, and Adminimize from below is version div 1.11.5

    This is great, thanks Frank. I will download and test with a couple of sites I am currently working on. Have gotten a lot of use out of this plugin over the years!

    Hello @bueltge
    I have tested the 1.11.5-dev, over WP 5.1
    So far so good.
    Let me know where I can write my comments about the testing.
    Regards

    Plugin Author Frank

    (@bueltge)

    Please leave the feedback on a new issue on github, that would be really helpful. Thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.